GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1
    Jr. Mechanic
    Join Date
    Oct 2009
    Location
    Near the beach!
    Posts
    129

    Default I need your help fast please

    Today I installed some sound dampener in my truck and everything went ok. I had a lot of leftover material so I decided to do install it on my doors. I did my passenger door first and disconnected everything without messing it up. After I put everything back in the right place and connected everything where it belonged, the passenger door window,lock or interior light won't work. So I have no clue what has happened and Advance Auto Parts says it could be a switch.


    So, right now, it is pouring outside and my passenger window is down. and my keyless entry won't work. I tried to roll up the window with my driver side window switch but it did nothing. It's almost as if I blew a fuse for the whole passenger door. Please help me as soon as you can because the plastic isn't keeping all of the rain out, and you would know what I mean if you live in FL.

    Also, the interior lights are on all the time too.

    2003 Silverado 1500
    Superchip Programmer
    20" Black Powdercoated Silverado SS Rims
    35 watt 5000k Low Beams
    55 watt 6000k High Beams
    Functional Ram Air intake with K&N filter
    Custom Side Exit Exhaust
    3% Window Tint
    Custom Painted Grill
    Halo Projector Fog Lights
    Outdoor Soundsystem
    2 12" Kenwood Carbon Fiber Cone Subs
    Custom Black Headliner

    :fighting0072:
    [/COLOR][/LEFT]

  2. #2
    Jr. Mechanic
    Join Date
    Oct 2009
    Location
    Near the beach!
    Posts
    129

    Default

    Could it be that I fried the passenger door control module?

  3. #3
    Legend
    TRPLXL2's Avatar
    Join Date
    Jan 2009
    Location
    Norwalk, Ohio
    Posts
    3,368
    Blog Entries
    8

    Default

    I seriously doubt that you fried the BCM, because none of your interior stuff would work including your windshield wipers. Did you have the battery disconnected when you did all of that stuff, because the electrical can do a lot of damage if you didn't disconnect at least the negative battery cable. Other than fuses and relays, I wouldn't know what else to say..........sorry.
    2004 Chevy Colorado
    LS1 5.7 swap/TBSS rear axle swap

  4. #4
    Jr. Mechanic
    Join Date
    Oct 2009
    Location
    Near the beach!
    Posts
    129

    Default

    Quote Originally Posted by TRPLXL2 View Post
    I seriously doubt that you fried the BCM, because none of your interior stuff would work including your windshield wipers. Did you have the battery disconnected when you did all of that stuff, because the electrical can do a lot of damage if you didn't disconnect at least the negative battery cable. Other than fuses and relays, I wouldn't know what else to say..........sorry.
    I didn't have the battery disconnected, didn't think of it at the time. Because I'm dumb. I think that I may have messed up a relay. But I'm going to pull out the whole passenger power lock and window switch tomorrow and hopefully there will be a simple blown fuse there.

    Other than that, how would I find out what it was and how to fix it?

  5. #5

    Wink

    Take a test light and see if you have power any where in the door. If you have power to the switches and they arent working than its a bad switch ok. No power to anything than find all relays and or fuses that apply and check them you can swap relays from something of the similar to test and vice versa by putting the one you took out into something that you know that works. I have taken my panels off while listening to the radion in my truck never had a problem the only thing you could have done was pinched a wire putting the panel back on.
    08 silverado Ext 4x4
    20's 285
    02 Blazer
    5-speed
    31 in BF Goodies
    Cold Air Intake

  6. #6

    Default

    just disconnect battery then reconnect happened in my escalade

Similar Threads

  1. Zero Emission Electric Vehicles? Not So Fast. - Fast Company
    By ChevyFan in forum Chevy Volt Forum
    Replies: 0
    Last: 03-27-2010, 01:20 AM
  2. Help K1500 Suburban cranks fast slow fast doesnt start
    By boyscout in forum GM Powertrain
    Replies: 1
    Last: 01-23-2010, 08:01 PM
  3. help!!! fast
    By zackyv55146 in forum Chevy Truck Accessories
    Replies: 2
    Last: 01-15-2010, 09:30 AM
  4. I need help fast!
    By Snyder729 in forum Chevy Truck Accessories
    Replies: 2
    Last: 11-24-2009, 08:48 PM
  5. Need help fast!!
    By Ryzzle in forum Audio, Video & Gadget Tech
    Replies: 3
    Last: 09-02-2009, 09:38 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •