GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1
    Jr. Apprentice
    Join Date
    Nov 2009
    Location
    Santaquin, Utah
    Posts
    26

    Default Front Diff problem

    Okay folks, there a lot of threads on this issue but I am getting more confused by the minute. I have a 1999 GMC Jimmy with the push button 4X4 (4 button). When I press the buttons everything works correctly except the front diff wont engage. The transfer case is working properly and the drive shaft is turning. There is a cable running to the diff then under the batt tray. The cable moves freely but there is no vacuum going to the diaphram. Tracing the lines back there is a switch on the fire wall but no vacuum to it either. Where do I go from here?

    Don't know if this helps but my selector switch for the heater/AC controls won't work either. just blows out all the vents. I have been reading about a vacuum line on the back of the motor near the distributer that controls both the 4X4 and the heat/AC controls. Could this be the problem? I have a vacuum line that goes no where and wondering if this "T" near the dist is where it should go.
    Last edited by jnbascom; 12-14-2009 at 12:47 PM.

  2. #2
    Sr. Apprentice brianj's Avatar
    Join Date
    Oct 2009
    Location
    New Hampshire
    Posts
    68

    Default

    I would say you are losing vacuum somewhere, and it sounds like you have found the spot.That would explain both problems.
    1995 chevy 2500:fighting0040:
    1996 tahoe
    1946 plymouth
    1946 ford
    1931 model a
    1975 H.D. sportster
    1986 Monte Carlo SS
    Many rusted , half finished projects- want to buy one? Cheap?? Please?!!

  3. #3
    Jr. Apprentice
    Join Date
    Nov 2009
    Location
    Santaquin, Utah
    Posts
    26

    Default

    Hooked up the vacuum line. 4X4 worked good for 2 tries and now it is stuck in 4X4 auto. I disconnected the vacuum line and it still is stuck in auto on the dash but the diff disconnected itself. What happened to cause this?

Similar Threads

  1. front diff
    By sinjin in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 10-11-2009, 04:07 PM
  2. '08 Front Diff Leak
    By BBC4EVER in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 10-07-2009, 07:47 AM
  3. 2500HD Front diff problem
    By timmerado in forum GM Powertrain
    Replies: 5
    Last: 03-26-2008, 10:48 PM
  4. Front Diff ?'s
    By Snotrocket in forum GM Powertrain
    Replies: 5
    Last: 03-25-2008, 08:42 AM
  5. front diff [Expired Topic]
    By carlos in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 11-26-2006, 04:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •