GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default Mud/Clay in waterjacket [Expired Topic]

    So back in July when gas prices started to get out of hand (at least in RI) I decided to do a run of the mill tune up, and figured I'd adjust the timing for optimal performance. While reaching around that pesky quick release to get to the distributor bolt, I bumped the quick release, and it snapped, leaving the threads in the manifold. I tried to use a reversed bit to back the threads out, unfortunately no luck. Being ever the practicing optimist, I tried to look at this as an opportunity, not a setback. So I decided now was just as good a time as any to replace the cam with something a little more beefy in the torque dept. Lets just say that opened up a whole new can of worms. My cam bearings were worn (as should be expected) but they were also cracked. Again trying to be the optimist I figured I could still do this job with the engine in the truck. I should have realized that I wouldn't be able to get the oil pan out to get the bearings out because of the front axle.

    So now, it's been forever, or at least it seems that way. I finally got my hands on an engine hoist, and I have the engine out, since it's out, I'm stripping it and rebuilding. Funny how this whole thing started with a simple quick connect that broke off.

    I just rotated the block in the stand, and out of the water jacket fell a couple clumps of what looks like packed clay. When I looked in the jacket, I found an even bigger clump that needed to be broken up to fall out. Now I'm curious, is that something I should have expected with an engine that has over 200k miles? There have only been three owners of this truck, and I can account for two of them, the third being the original owner.

    Could this be stop leak that someone put in the radiator at some point?
    Now I'm thinking about flushing out the water jacket, since having globs of crud in the block is certainly going to affect cooling.

    I just never expected to see something like that. :?

    Is this something anyone who does a high mileage rebuild should look for?
    Patrick
    Rhode Island


  2. #2

    Default RE: Mud/Clay in waterjacket

    ?? It could be something like that. Stop leak or some other type of similar product. Maybe someone got mad at them and poured sugar or something in the oil filler???

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

Similar Threads

  1. Looking for a new engine [Expired Topic]
    By dsbougher in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 06-26-2006, 09:00 AM
  2. What now [Expired Topic]
    By beastsuburban in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 05-09-2006, 08:29 PM
  3. Too much? [Expired Topic]
    By beastsuburban in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 05-03-2006, 10:48 AM
  4. Thermostat??? [Expired Topic]
    By rt1092 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 02-25-2006, 05:48 PM
  5. Welcome [Expired Topic]
    By ChevyFan in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 06-16-2005, 11:57 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •