GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default odometer problem

    hey guys i have a 2004 silverado 1500 with 5.3 and 4x4. just put a new water pump in and hopped back in the truck to find the odometer not working. it was before. i did disconnect the battery before starting the pump. all other gauges and lights are working, found no codes in the system. buttons on steering wheel for info center are not working. please help i'd rather the wife didn't hit me for wrecking her truck.

  2. #2
    Master Mechanic TritonBoulder47's Avatar
    Join Date
    Nov 2009
    Location
    Tunkhannock, PA (North East)
    Posts
    809

    Default

    Try disconnecting the battery for an hour... This should reset the computer... Then connect it back up and see if that works... Thats the only thing I can think to try...

    Tim a.k.a. Da' Boulder

    2003 Chevrolet Avalanche Z71 - Custom Emergency Response POV

    Firefighter, Fire Policeman, Ambulance Driver, Rescue Tech, Emergency Lighting Installer

    Tint, 20's, Bull Bar, Intake, Exhaust, Billet Grill, Stereo, Custom Console, Emergency Equipment, and the list goes on...

  3. #3

    Default

    Thanks i'll give it a shot. its just weird that it happened now. i didn't even have to touch anything electrical to do the water pump except for the battery

  4. #4

    Default

    Ok must have just been a gremlin. went out to the truck today and every thing was back to normal. must have magic fingers or something

  5. #5
    Master Mechanic TritonBoulder47's Avatar
    Join Date
    Nov 2009
    Location
    Tunkhannock, PA (North East)
    Posts
    809

    Default

    Glad to hear it's fixed...

  6. #6

    Default

    did the reading change or was it completely back to normal?

  7. #7

    Default

    all back to normal as if nothing happened

  8. #8

    Default

    Cheers!

Similar Threads

  1. No speedometerand odometer
    By okysmokey911 in forum Chevy C/K Truck Forum
    Replies: 0
    Last: 02-21-2010, 01:31 AM
  2. Odometer discrepancy??
    By fixinta7 in forum GM Electrical Tech
    Replies: 0
    Last: 11-30-2009, 05:21 PM
  3. way to fix trip odometer ?
    By RATRODKING in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 11-10-2009, 03:22 AM
  4. help...no speedo/odometer
    By braspu in forum General Chevy & GM Tech Questions
    Replies: 11
    Last: 08-18-2009, 02:49 PM
  5. Odometer Problem
    By Dinner in forum Audio, Video & Gadget Tech
    Replies: 4
    Last: 03-06-2009, 04:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •