GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Front speakers not working

    I have a 2004 Z71, a few months ago my speakers began to squall really bad then they just quit working. I changed the factory head unit with another factory head unit, still didn't fix it. Any suggestions.

  2. #2

    Default

    Quote Originally Posted by Gremlin View Post
    I have a 2004 Z71, a few months ago my speakers began to squall really bad then they just quit working. I changed the factory head unit with another factory head unit, still didn't fix it. Any suggestions.
    I had the same Problem with mine.I ending up getting New Speakers Front & Rear.Just to be sure take a look at the Connection's at the Speakers??

    If you do get New Speakers here is a link,that will help in taking off your Door Panels.

    http://www.bodyshopzone.com/archives...ove_02_CK.html


    Merry Christmas....

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3
    Jr. Engineer lsutoms's Avatar
    Join Date
    Sep 2009
    Location
    baton rouge louisiana
    Posts
    281

    Default

    buddy has the same problem in an 01 and put speakers in and it was back to new

Similar Threads

  1. Front Speakers
    By bigbluesub in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 10-06-2009, 07:12 PM
  2. Front Speakers
    By Tommy Tahoe in forum Audio, Video & Gadget Tech
    Replies: 4
    Last Post: 05-23-2009, 08:16 PM
  3. No Front Speakers? No Chimes?
    By Hwy St*r in forum Audio, Video & Gadget Tech
    Replies: 4
    Last Post: 02-08-2009, 06:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •