GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 93 Silverado weird electrical gremlin. help!!

    Here is a weird one for ya. I am about to buy a 93 Silverado extended cab 2wd tomorrow. i am getting it for a price where i hope i can not loose any money on it if i cant fix the problem. The owner tells me that everything works great until you turn on the headlights. When you turn on the headlights all interior power is lost and the turn signals dont work. he said gauges quit, turn signals quit, even the power windows quit.

    I am guessing this is a bad ground or 2 wires rubbing together mabye. Just thought i would throw this out there and see if anyone has had the same experience and mabye cut down my troubleshooting time

    Thanks for the help, look forward to seeing if anyone can diagnose this before i go to look at the truck.

    oh yeah, i also forgot about the blower motor. it does not work at all. i am assuming bad motor, switch, resistors or wiring. what is the most common failure on the blower motor system? I dont think the blower motor problem is related to the other electrical issues but i have seen weirder things happen!!

    Thanks Again!!!!
    Last edited by rustyironhead; 12-29-2009 at 09:43 PM.

  2. #2
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default

    It could be as simple as a bad ground, or even a bad headlight switch. Or it could be one of those Katrina swap rats from hell. As far as the blower, resistors are more common, followed by the actual blower motor. Both are easy to replace. Good luck. Keep us posted, and take some pictures of your handy work to share with us here at GMTC.
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

  3. #3

    Default

    Heres an update. I looked at the truck in person today. Here is what i found.

    Gauges work if the headlights are not on.

    If you try to use any high current interior device such as the power windows, blower motor, headlights etc.. Then the gauges quit working, the buzzer goes off, and the drvice you are trying to use does not work. The only way to get things back to normal is to hit the off button on the heater control. The problem is a little weirder than i origionally thought. With just a visual inspection i noticed the ground from the battery to the right fender looks horrible. I plan to bring the truck home in a few hours. I will let you know what i find. Until then i would appreciate any other ideas y'all have. Any other body grounds i should look at?

  4. #4

    Default

    crazy stuff man keep us updated...
    1997 K1500 Silverado 4X4. Black Exterior, grey/black interior. 35X12.50X15 wheels and rubber, ProComp 6inch lift 6 shocks in the front 2 in the rear, 3 inch body lift, a few cosmetic mods. Nothing major. Custom leather interior, and stereo upgrade is the future mods.


  5. #5

    Default

    Another update... Truck is home. Looked it over for about an hour. All power and grounds under the hood test good. Have the dash partially disassembled now. Everything so far seems to have good power and ground with the exception of the dash lights fuse. The dash light fuse shows 14 volts with the key on, but the test light barely illuminates when testing that fuse. However with the test light on the fuse and pressing the window down button the light is suddenly really bright!! That's as far as I had time to test. I am wondering if there is a short in the dash or a bad ground? I'm getting more confused!!

Similar Threads

  1. 06 chevy silverado 5.3L making weird tappin noise
    By jobrien836 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 10
    Last: 03-27-2012, 12:51 PM
  2. 02 Silverado acting weird.
    By USAFZ71 in forum GM Powertrain
    Replies: 2
    Last: 12-15-2009, 09:34 PM
  3. 260 mile gremlin
    By i_build in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 19
    Last: 07-12-2009, 09:19 AM
  4. 97 1500 Silverado weird Brake Light Problem
    By pabes in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 5
    Last: 11-10-2008, 02:21 PM
  5. Weird Issue with 07 Silverado
    By ctruhn in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 9
    Last: 07-02-2007, 11:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •