GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 3 123 Last Post byLast Post by
Results 1 to 10 of 30
  1. #1
    Sr. Apprentice itsabowtime2's Avatar
    Join Date
    Dec 2009
    Location
    TN, via MI, OH and NY
    Posts
    61

    Default Bank 1 to lean, trouble code, help

    The check engine light came on this morning.

    Bank 1 is running lean. I'm thinking a vacuum issue, or perhaps an O2 sensor. But which O2 sensor?

    Truck had a rough idle this morning on start up. Once warm it was fine. Lighht came on after a short trip to the store.

    Has anyone had the same issue/code? What solved it for you? I have new plugs and Sea Foam waiting for a warm day to do, provided I can solve the check engine light issue. I have disconnected the battery to see if the code comes back.

    Thanks for any help.
    Last edited by itsabowtime2; 01-03-2010 at 07:56 PM.
    2003 Chevy Tahoe Z71 4x4
    Other vehicles:
    2000 F250 Super Duty Crew Cab 4x4
    2005 Dodge Grand Caravan
    Toys:
    3055 Bayliner Ciera (2x SBC)
    Sea Doo GTX Limited
    Sea Doo XP (currently rebuilding the engine)

    Life is short. Boats and trucks are cool.

  2. #2

    Default

    I just had the same problem recently but it was bank 1 and bank 2 were lean. The truck would start up and rev to about 2k rpms then it would drop down to a rough 4-500 rpm. It only did it when it was cold outside, I chased down a few little things but it ended up being the intake gaskets. The gaskets were $40 and about 1.5 hours of my time, didnt even have to drain the coolant. My truck has 136k on it
    02 silverado
    4/6" djm kit
    notched frame
    22x9.5 u2-55's
    one part, one paycheck, one week at a time

  3. #3

    Default

    What trouble code do you have?

  4. #4
    Sr. Apprentice itsabowtime2's Avatar
    Join Date
    Dec 2009
    Location
    TN, via MI, OH and NY
    Posts
    61

    Default

    Had a ran at a parts store. The counter sales person said it was "Bank 1 is running lean"

  5. #5

    Default

    Me too p0171,po174. bank 1&2 too lean!!!

  6. #6

    Default

    use some carb cleaner to find the leak while its running

    99 tahoe 2 dr. 4x4 7.4 4L80-e NP246, SAS, dana 60 hp, sterling 10.5 rear, gibson headers, and alot of tricks of the trade !!!!!!IF YOU'RE NOT CHEATING YOUR NOT TRYING!!!!!!!!

  7. #7
    Sr. Apprentice itsabowtime2's Avatar
    Join Date
    Dec 2009
    Location
    TN, via MI, OH and NY
    Posts
    61

    Default

    Quote Originally Posted by BLK-Z71 View Post
    Me too p0171,po174. bank 1&2 too lean!!!

    What do you think is causing it? Vacuum leak is my first guess. Intake gaskets, as a member suggested may be my first stop.

  8. #8

    Default

    my truck is goin in on wed. i'll let you know what happens!!

  9. #9
    Sr. Apprentice itsabowtime2's Avatar
    Join Date
    Dec 2009
    Location
    TN, via MI, OH and NY
    Posts
    61

    Default

    Quote Originally Posted by BLK-Z71 View Post
    my truck is goin in on wed. i'll let you know what happens!!
    Thanks.

    I connected the battery this morning and the light stayed on, until the engine got up to operating temp, then the check engine light went off. I love chasing Gremlins.

  10. #10

    Default RE`

    Anyone find out what the code was? I have the same thing lol
    Joser
    2001 Silverado 5.3L
    13% tint all around
    7" Fabtech lift kit w/ leveling kit
    HD front end conversion
    Blacked out Billet Grille w/ Black Bow-Tie
    33x12.5x20 on 20x10 Fuel Hostage
    Smoked out tail lights
    Dual Flow Masters/ Exhaust Cut outs
    K&N CAI
    Custom Tuner
    Corvette Servo
    180 Stat
    10K HIDs


    "Spending money on things we dont need to impress people we dont know"

Page 1 of 3 123 Last Post byLast Post by

Similar Threads

  1. system to lean bank 1 and 2 codes what should i do
    By cliff334 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 01-30-2010, 11:43 AM
  2. trouble code 171
    By snascar29 in forum Chevy Colorado Forum (GMC Canyon)
    Replies: 1
    Last: 12-10-2009, 06:38 PM
  3. trouble code
    By challutz in forum Chevy C/K Truck Forum
    Replies: 2
    Last: 11-21-2009, 07:37 AM
  4. Trouble code
    By T1743 in forum GM Diesel & DuraMax
    Replies: 1
    Last: 11-21-2009, 02:11 AM
  5. P00174 Bank 2 Running too lean
    By Schwindle in forum Performance & Fuel
    Replies: 2
    Last: 08-13-2009, 05:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •