GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5

Thread: stuck in 3rd

  1. #1

    Default stuck in 3rd

    hey everyone.. new here and looking for some help.

    i have a 2003 silverado hd...8.1 with 5 speed allison transmission with hmm...about 93000 miles on it.
    and it just started acting up. i first notice when i went to put it in park and the doors didn't unlock...but thought nothing about it.. and then when i went to put it into "D"rive the little bar under the selection didn't show up.. so i drove it anyways...goes through first second and into 3rd but not 4th or 5th... sometimes i can pull over...but it into park...shut it off and then start it back up...and it will go up into 4th and 5th...but still no little bar under the "D"rive... i read the DTC's and got........

    po101- mass/volume air flow circ range/perf
    po132-oxy senser circ hi voltage (bank1, sensor2)
    po134-oxy senns circ no activity dectected (bank 1, sensor 2)

    the mass air flow...i would take it would be from the k@n air filter on it...i took it out..put stock air filter in...and tried to clean the maf sensor up with brake cleaner...
    the o2 sensor i bought one for advance auto...got under it to but it in.......but for some reason...im out of the loop...the only 2 sensors i can find...are on each of the headers..i dont see a second one on the one bank...i found places where they would go..but there isn't anything there but a bolt plugging the hole...

    but the thing is the dtc's aren't that big of a deal...i gotta get this transmission straight...any ideals???

    thanks for the help

  2. #2
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default

    Sounds like the transmission is in "limp" mode. Probably your best bet is to get an estimate from a qualified shop.
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

  3. #3

    Default still at it..

    still trying to get this solved...i started it up a little while ago...and everything ran just the was it was supposed to run...pulled it to the shop to but the battery on the charger....... looks like a big pill from the gm shop and if no one can come up with any ideals ..????

  4. #4

    Default

    Quote Originally Posted by gecko094pat View Post
    ...and tried to clean the maf sensor up with brake cleaner...
    Never use brake cleaner on a MAF or MAS sensor, always use sensor safe MAS/MAF cleaner, brake cleaner will leave a residue that can give false readings at best or worse case permanently destroy the sensor.

    Check all the connectors from the transmission for security and water intrusion.

    I just saw a comercial about AAMCO doing free diagnosis on vehicles, might be worth a visit to them for a diagnosis, not sure about a repair from them as I've heard mixed results.

  5. #5

    Default

    If it works OK sometimes and then acts up it's probably the NSBU switch. Keep in mind you need an Allison scan tool to see some transmission codes. If the transmission is stuck in third then there will be codes stored. Also a low battery will cause the NSBU switch to act up. Make sure you have a good fully charged battery.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

Similar Threads

  1. I was just a lil stuck
    By MonTyMarine in forum Photo & Video Gallery
    Replies: 21
    Last Post: 11-13-2011, 08:45 AM
  2. stuck in 4hi
    By dyckweed7 in forum GM Powertrain
    Replies: 3
    Last Post: 01-11-2009, 05:25 PM
  3. stuck
    By 81scottzy in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 12-15-2008, 12:57 AM
  4. Got stuck in the mud......
    By DirtDog in forum Photo & Video Gallery
    Replies: 18
    Last Post: 02-17-2008, 04:06 PM
  5. stuck in 4x4
    By mailman in forum Chevy Blazer Forum (GMC Jimmy)
    Replies: 4
    Last Post: 01-09-2008, 06:08 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •