GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default Compass/temp mirror acting wierd.

    A few days ago the we decided to do a family dinner, at McD's
    It was raining, and while we sat waiting for our order in the drive through I noticed that each time the wipers would come on (they were on intermittent) the compass, and thermometer in the rear view mirror would go nutty. It would actually look like it was in test mode. All available characters would light. So it would look like boxes with asterisks (*) inside them. Then it would go back to normal while the wipers were at rest. I'm not too concerned about it just yet, if it happens again or more frequently I'll have it checked.

    But I thought it was weird. Anyone else experience this?
    Patrick
    Rhode Island


  2. #2

    Default

    Check your wiring connections that run along the windshield to the mirror, they could be loose and the wipers vibrating the window could mess with it.
    Gary

    99 K 1500 Suburban
    78 Silverado Big 10 w/factory 454
    00 S-10 Blazer
    1976 Trans Am
    1980 Honda CB900 Custom

  3. #3

    Default

    Did this straighten itself out?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  4. #4

    Default

    Have you turned wipers on since with out it raining? Seems weird.



    Jamie

    2007 Ford E250(Work van) (Ya, Ya, shut up!)
    1996 GMC Sierra SLE 1500 5.7L/4L60E

  5. #5
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default

    I've seen that on my Silverado, but not with the wipers. (Not much rain in the Mojave) More often than not it occurs first thing on start up. Haven't seen it lately though, but I don't always stare at the mirror when I'm cranking her up.
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

  6. #6
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    We use Rain-X in the washer reservoir, so the wipers don't always need to be used.

    I forgot to post on this again. The problem never actually happened again, but the root cause showed up about last month when the wife got stuck at work (truck wouldn't start). Her step father went to bail her out. Not sure how it happened, but the positive terminal of the battery was broken nearly off. Almost like someone over torqued the side terminal bolt. when the Avalanche finely made it home, I went to do a once over, and the positive line, and the battery contact came off in my hand.

    I popped a new battery in, and since then there have been no electrical issues.
    Patrick
    Rhode Island


  7. #7

    Default

    The Avalanche I take it is just for the wife? You need to be more proactive if its the wifes or you won't be gettin' any...



    Jamie

    2007 Ford E250(Work van) (Ya, Ya, shut up!)
    1996 GMC Sierra SLE 1500 5.7L/4L60E

  8. #8
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    True...true...

    What I need to do, is find a spare moment to drop that 454 back into the burb....lol
    Patrick
    Rhode Island


  9. #9

    Default

    Any repeat of this issue?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

Similar Threads

  1. Temp/Compass in Mirror?
    By hdbat3 in forum GM Electrical Tech
    Replies: 13
    Last Post: 03-13-2012, 07:24 PM
  2. 04 silverado temp/compass stopped working
    By drumm14 in forum Audio, Video & Gadget Tech
    Replies: 1
    Last Post: 05-26-2009, 05:24 PM
  3. Compass/ Temp Mirror Swap
    By udderchaos in forum Audio, Video & Gadget Tech
    Replies: 0
    Last Post: 03-09-2009, 10:15 PM
  4. Compass in mirror
    By Aeropagus in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 4
    Last Post: 06-01-2008, 07:33 AM
  5. Compass/temp mirror quit......
    By jbhofc in forum Audio, Video & Gadget Tech
    Replies: 3
    Last Post: 05-18-2008, 02:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •