GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 31

Hybrid View

  1. #1

    Default common problems 1999 Suburban 350 CID 5.7L

    Despite extensive searching and lots of hours reading posts I have yet to find a list of common problem for the 1999 Suburban. Or at least the 96-99 Burbs with the Vortec 350. Basically the only common problem that I have seen mentioned is the intake gasket. Surely there is more than just the intake gasket that seems to fail on these Burbs.

    I read on consumerguideauto.com that the intakes were a problem thru 1998. Below is the excerpt from their site:

    Oil leak: Oil loss and fouled spark plugs result from intake manifold gasket leaks. (1996-98)

    Did they fix the intake problem on the 99 models or is it the same as on the previous years?

    Also, could anyone list for me other common problems associated with these models (96-99)?

    Thanks in advance!

  2. #2

    Default

    Quote Originally Posted by markf1971 View Post
    Despite extensive searching and lots of hours reading posts I have yet to find a list of common problem for the 1999 Suburban. Or at least the 96-99 Burbs with the Vortec 350. Basically the only common problem that I have seen mentioned is the intake gasket. Surely there is more than just the intake gasket that seems to fail on these Burbs.

    I read on consumerguideauto.com that the intakes were a problem thru 1998. Below is the excerpt from their site:

    Oil leak: Oil loss and fouled spark plugs result from intake manifold gasket leaks. (1996-98)

    Did they fix the intake problem on the 99 models or is it the same as on the previous years?

    Also, could anyone list for me other common problems associated with these models (96-99)?

    Thanks in advance!
    I believe the fuel pump is a common failure item.

    The other complaint I've seen is brakes, but then I think that is because the vehicle didn't come with adequate brakes from the factory. The 2000+ Burbs have lot better factory brakes.

    Not sure if it is mentioned but engine oil cooler lines possibly? I bought mine with low miles and I was leaking oil from the cooler lines. The guy in the shop seemed to mention it was a common issue. Less than 100k on my odometer when I experienced that problem.

  3. #3
    Master Mechanic tattooed4life's Avatar
    Join Date
    Apr 2008
    Location
    Stevensville MI
    Posts
    886

    Default

    The most common things I see and have replaced on all 96-99 obs trucks and suv's

    1) Intake Gaskets
    2)Fuel Pump
    3)Heater hose fitting on manifold-factory is aluminum needs to be changed to steel aftermarket
    4)Flush pink radiator fluid and go back to green-pink **** actually eats away aluminum which causes failure of #3 and other engine components which can result in an overheat
    5)Distributor gear wearing causing "play" in the timing

    This is all I can think of that seem to be everyday repairs at the shop with these trucks. You have all of the common issues alos but the majority of them are inexpensive easy fixes for a do it yourselfer.
    1997 Chevy K3500
    4x4 X-Cab Dually
    454 Dual Exhaust

  4. #4

    Default

    X2 on tattoo's list and definetly dump the pink stuff factory uses it to seal any leaks that happen during build( It co-wag-ulates) Dont spell check I just sounded it out. Anyway the fuel pump gets loud and they go at different times but they go out and the fuel pressure regulator diaphram cracks and causes hard starting due to raw fuel being sucked into maifold from vac. line

    99 tahoe 2 dr. 4x4 7.4 4L80-e NP246, SAS, dana 60 hp, sterling 10.5 rear, gibson headers, and alot of tricks of the trade !!!!!!IF YOU'RE NOT CHEATING YOUR NOT TRYING!!!!!!!!

  5. #5

    Default

    Its the O ring on the tanks that would be #6 good call CADDIAC

    99 tahoe 2 dr. 4x4 7.4 4L80-e NP246, SAS, dana 60 hp, sterling 10.5 rear, gibson headers, and alot of tricks of the trade !!!!!!IF YOU'RE NOT CHEATING YOUR NOT TRYING!!!!!!!!

  6. #6

    Default

    I've had my 99 for two years now, put 30k miles on it (120k now). I've done the fuel pump twice and the new AC Delco part still sings. They apparently didn't do the sender too as my fuel gauge shudders still. I found this thread by looking up the aforementioned radiator issue. I just found my slow leak...left side tank O ring. Also time for tie rod ends...was told they are a weak link. I also definitely agree with the weak factory brakes.

    I researched the fuel pump issue and it seems to be a case of incorrect wire gauge choice. I'm planning to build a new harness with heavier gauge wire.
    Rob
    1999 Suburban C1500 LS 5.7 K&N filter, VentVisors, debadged aka "LAAT/i...Larty"
    1994 C2500 454. Ex-Forest Service beastie. aka "Redneck"
    2006 Saturn Ion...the Wife's car.
    Empty spot that needs a Jeep...

  7. #7
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,356

    Default

    Quote Originally Posted by Gryphon View Post
    I've had my 99 for two years now, put 30k miles on it (120k now). I've done the fuel pump twice and the new AC Delco part still sings. They apparently didn't do the sender too as my fuel gauge shudders still. I found this thread by looking up the aforementioned radiator issue. I just found my slow leak...left side tank O ring. Also time for tie rod ends...was told they are a weak link. I also definitely agree with the weak factory brakes.

    I researched the fuel pump issue and it seems to be a case of incorrect wire gauge choice. I'm planning to build a new harness with heavier gauge wire.
    the fuel gauge shudder is most likely the cluster not the fuel sender. as for me I have replaced my pump once at 110,000 miles and the intake gasket went around 85000, other then that its just nromal stuff for an 11 year old truck with 127000
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

Similar Threads

  1. Common problems on a 90 K1500
    By gt1009 in forum Chevy C/K Truck Forum
    Replies: 1
    Last Post: 04-28-2009, 11:25 PM
  2. 1999 suburban starting problems
    By junkbin in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 11-20-2008, 05:11 PM
  3. 1999 Tahoe ABS Problems?
    By cbarnum in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 0
    Last Post: 06-20-2006, 10:35 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •