GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Question 1991 chevy 1500 charging problems

    I have a 1991 chevy 1500 4X4 350. i was driving it and the battery light came on so i checked the voltage and the alternator was not putting out. so later i got back in my truck and started it up and the alternator was charging again. when im driving every once in a while the headlights will get real bright and the battery light will come on as if its charging real high, this happens for a few seconds and returns too normal..... could it be my alternator? does the alternator have an internal voltage regulator???

  2. #2

    Default

    Well it's a one wire alternator, correct? If so I would think it has to be internal. I'm working on a 1990 and his setup seems to have a similar problem. The battery and alternator have both been checked and neither are bad. And since it's a pretty simple system, there aren't too many things that can go bad. I'm just guessing yours is a one wire alternator though.

  3. #3

    Default

    Yes, it does have a voltage regulator. But the brushes could be going and just hit and miss. Or the stator could have a bad spot.Since you've tested the battery, it's a safe bet you need an alternator. Just be sure to check out all your connections first to make sure there is no corrosion or loose wires/connections.

  4. #4

    Default

    I'm having a similar problem I lose voltage for a few minutes and then it returns to normal. got so bad i had to change the alternator and battery
    and the module went . now the truck runs well I thought I was all set when 2 days later i am losing voltage again . it is driving me nuts because its intermitant
    i added grounds to body,frame motor. if anyone has any ideas i would appreciate it thanks..

  5. #5
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    Quote Originally Posted by john k View Post
    i added grounds to body,frame motor. if anyone has any ideas i would appreciate it thanks..
    John, This sounds like a floating ground problem. Check your connections where you put the battery negative to the engine & engine ground to frame. No paint or rust here, it must be clean shiny metal to metal contact. If batt to frame & frame to engine grounds are good & the alternator ground wire you added is also good, then check your engine to body grounds at the firewall.
    Last edited by stephan; 06-10-2011 at 12:12 AM.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  6. #6
    Sr. Engineer
    Join Date
    Aug 2009
    Location
    Virginia Beach, VA.
    Posts
    337

    Default

    I have a 91 350 also.
    Had a similar problem last summer.

    The cicuit itself is pretty simple....
    If you have used a Volt meter and confirmed that voltage is right (when on) at the alternator (~14v),
    Check the voltage back at the battery, and see if you read the same voltage.....my guess is maybe not.

    Then if you also have an ohm meter, check resistance between the two points, alternator and batter terminal.
    Should be little to no resistance.....if there is resistance, then you have a bad wire.

    What fixed my problem, was taking the wiring harness that runs on the passenger side of the engine block and pulling it towards the firewall and putting a zip-tie in place to hold it there. So I probably have a bad wire and just am too lazy to deal with changing it out. :D

Similar Threads

  1. 1991 Chevy 1500 4x4--WONT START! And will die
    By WhiteZ in forum Chevy Truck Tech Forum
    Replies: 4
    Last: 07-23-2010, 06:35 AM
  2. Replies: 0
    Last: 12-20-2009, 05:50 AM
  3. Replies: 1
    Last: 07-25-2009, 12:32 PM
  4. Parts interchangeability 1991 chevy 1500
    By maxpower_454 in forum Chevy C/K Truck Forum
    Replies: 6
    Last: 05-26-2009, 01:31 PM
  5. 97 chevy 1500 problems help
    By Evan in forum GM Powertrain
    Replies: 2
    Last: 02-10-2009, 08:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •