GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Help K1500 Suburban cranks fast slow fast doesnt start

    My 1997 k1500 suburban had been cranking normal then slows/stops, then normal and starts especialy when it is warmed up or hot. it has had his problem since i got it about a year and a half ago, a couple of times it wouldnt start, then a few hours later no problem at all, I took it to a mechanic several months ago and he said he adjusted the timing some but couldn't totally adjust it right... But it did start better after his adjustments. however it now will not start at all now.

    It has been suggested that the timing chain, ignition module, Pick-Up Coil, Ignition Control Module, Crankshaft Position Sensor, Camshaft Position Sensor and the ECM should be replaced.

    this is a K1500 1/2ton Sub 4WD 5.7L SFI 8cyl Vortec with 4L60E Transmission and I don't know how to adjust the timing at all on this type of motor as i thought it was adjusted by the ECM.

    All I can say now is HELP

  2. #2
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default

    Ok, back to basics. An ICE (internal combustion engine) needs just a few things to run.

    1. Fuel
    2. Spark
    3. Timing
    4. Compression
    5. Air

    1. Fuel......................Measure the fuel pressure. Will it start with starting fluid?
    2. Spark...................Are you getting spark to the plugs?
    3. Timing..................Needs to be at factory spec.
    4. Compression........Almost a given, but can be measured.
    5. Air........................(O2 needed for life and combustion, pretty much a given, no test required.)

    Check those and post your findings. How many miles on the engine, and has it been rebuilt/replaced?
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

Similar Threads

  1. Truck cranks but no start
    By smokey308 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 11-16-2010, 09:54 PM
  2. Zero Emission Electric Vehicles? Not So Fast. - Fast Company
    By ChevyFan in forum Chevy Volt Forum
    Replies: 0
    Last: 03-27-2010, 01:20 AM
  3. cranks but won't start
    By duece209 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 5
    Last: 01-07-2010, 06:24 PM
  4. 96 K1500 Cranks but won't start
    By mattress67 in forum General Chevy & GM Tech Questions
    Replies: 10
    Last: 09-24-2009, 12:51 PM
  5. 2000 Savanah Van cranks but won't start
    By SuperMatt in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 07-14-2009, 09:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •