GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: starts and dies

  1. #1

    Question starts and dies

    I have a 98 GMC K1500 4x4 5.7 it will start then die after a second or so. My security light goes off the fuel pump will run , I replaced the fuel filter ,checked the relays in the fuse box and nothing changes. My oil pressure reaches about 40 or so before it dies at around a 1000 rpm I have not checked the mass air flow sensor and I did check the crankshaft position sensor, looked at and cleaned the dist cap and rotor. Any suggestions would be great . I have not checked the fuel pressure yet either. I looked at the mass air sensor , it looked fine and I also sprayed starting fluid into the air inlet after the air filter and tried starting the truck and it ran twice as long until it ran out of the fluid I am thinking my fuel pump is either weak or the filter in the tank is pluged . Still looking.
    Last edited by paidtofit; 01-23-2010 at 10:41 PM. Reason: update

  2. #2

    Default

    Is the security light flashing

    99 tahoe 2 dr. 4x4 7.4 4L80-e NP246, SAS, dana 60 hp, sterling 10.5 rear, gibson headers, and alot of tricks of the trade !!!!!!IF YOU'RE NOT CHEATING YOUR NOT TRYING!!!!!!!!

  3. #3

    Default

    No my security light comes on when I turn the ignition on and shuts off after maybe 30secs to a minute and my key is just a plain key without a security chip in it that I can see. I tried my diagnostic reader and it has a linking failure and won't tell me any codes.

  4. #4

    Default

    Might want to see how much fuel pressure you have.

    '96 K1500, 5.7
    6" RCD
    35" Toyo M/T On 16" Black Raceline Raptors
    4.56 Yukon Gears w/ TruTrac Rear
    S&B CAI
    Dual Flowmaster 40's
    Camo Wet Okoles
    Line-X Bedliner
    De-Badged


    NW BlackDiamond Edition

  5. #5

    Default

    I was able to check my pressure and it is almost 70# when I first turn my key on and the pump runs a few seconds and shuts off. Then as soon as it shuts off my pressure starts dropping to zero. When I turn the key over and start the truck it is around 60 - 65 # and drops to zero after my truck dies . Not sure if my check valve is bad and it won't keep pressure? Hopefully it's not my pressure regulator . Any clues as to where I should look further ?

  6. #6

    Default

    you probaly have it fixed by now but you might check your oil pressure sender

  7. #7

    Default

    Did you fix this? My 97 Suburban 5.7 has a similar issue.

  8. #8

    Default starts and dies

    Quote Originally Posted by jamesretzolk View Post
    you probaly have it fixed by now but you might check your oil pressure sender
    No I haven't fixed it yet , but where do you find the oil pressure switch since it might just be a bad connection? Cause something is basically telling my fuel pump to not to run after the initial run when you turn the key. I tried doing some searching for the switch on the internet but I can't find location just ones they want to sell me. Any help would be great. Thanks Ken

  9. #9

    Default

    No I am still trying to fix it seems like my fuel pump isn't being told to run once my truck starts. If that might be security issues , or an oil pressure switch , or a bad computer module ( hope not) or what the problem is I am not sure . I am laid off right now and can't afford to throw money at parts that are not broke to chase down loose ends. I am still looking at it and will post if I find something out. Please do likewise as the dealerships just want me to bring it in for them to fix. Thanks Ken

  10. #10

    Default

    Have you tried a relearn- go to crank pos- release.-leave key in on pos. wait till security light goes out-- repeat -- dont go to the off pos. during this, might take three times

    99 tahoe 2 dr. 4x4 7.4 4L80-e NP246, SAS, dana 60 hp, sterling 10.5 rear, gibson headers, and alot of tricks of the trade !!!!!!IF YOU'RE NOT CHEATING YOUR NOT TRYING!!!!!!!!

Page 1 of 2 12 LastLast

Similar Threads

  1. truck starts then a sec later dies...
    By Jcloud in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 07-08-2010, 06:03 PM
  2. Starts and dies code 35?
    By demo1024 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 02-20-2010, 01:42 PM
  3. starts then dies
    By jeeptj19992001 in forum GM Powertrain
    Replies: 6
    Last Post: 01-13-2010, 02:23 PM
  4. Starts then dies.
    By tkbbn in forum Chevy C/K Truck Forum
    Replies: 5
    Last Post: 04-21-2009, 08:56 AM
  5. thirsty starts but dies...'91 ...7.4L(454)
    By ikeslikes2 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 01-04-2009, 06:55 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •