GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default 1999 chevy silverado fuel pump not working

    I have a 5.3 engine and its gettin no fuel, Checked all fuses and relays and beleive to all be good.I tested them by changing out the relay with another one beside it since there the same and all the fuses are good, now I ordered a pump off ebay brand new,but it didnt come with a black module on top of pump,just a hole for my old one,i think its called a pressure switch or pressure sensor,I am not gettin fuel still,I dont hear a noise inside fuel tank. i tested old pump by hooking wires straight to battery and it works, so what can be wrong,can it be the pressure switch since it my old one? Is this what its called? or is there something else i should be checking, thank you in advance Doug

  2. #2

    Default

    Sounds like power is NOT getting to the pump connector. Does the relay energize for 2 seconds when the key is first turned "ON"? Does power get to the pump connector. You need a schematic and a DVOM or test lite. Helm makes the factory manuals for GM, but you can also use Alldata or Mitchell.

  3. #3

    Default test lite

    I have not checked the power yet with test lite because its snowing here,but my bet is that there isnt power to it,because its a new pump and turns out the old pump is good. I think its the oil pressure switch sense this is tied into circuit or crankshaft sensor. does the fuel tank pressure sensor in top of fuel pump have anything to do with the circuit? cause i had to use my old one

  4. #4
    Moderator

    dwill3015's Avatar
    Join Date
    Jan 2007
    Location
    Yacolt, Washington
    Posts
    4,338
    Blog Entries
    2

    Default

    Moved to fuel and performance
    Darcy
    Washington State
    2006 Silverado 2500HD LT3 4X4 CC SB Duramax LBZ
    Tuff Country 6" lift, 35" Toyo M/T's on 20" Ultra Peacemaker wheels, Quadzilla Stealth2 programmer, Diamond Eye 5" cat-back exhaust, factory Special order color Yellow.

  5. #5

    Default

    This answer fixed my problem----->
    Hello, the pcm powers the fuel pump relay, thus powering the fuel pump. have you checked the ecm b fuse 20 amp. this fuse is power for one side of the relay, then the pcm powers the control circuit of the relay. the relay also has one ground. in order for a relay to work, you must have one power feed, one ground circuit, and one control circuit. in your case the pcm.
    the ecm b fuse is in the underhood fuse block!!!


    It was my ecm b fuse,didnt know to check this one,i am puttin more infor here,thanks everyone---->>>
    When the ignition switch is ON, the PCM activates the in-tank fuel pump. The fuel pump remains ON as long as the PCM receives reference pulses from the ignition system. If there are no reference pulses, the PCM turns the fuel pump OFF after about 2-3 seconds. The pump delivers fuel to the fuel rail and injectors, then to the pressure regulator, where the system pressure remains at 379-427 kPa (55-62 psi) while the fuel pump is running. Excess fuel returns to the fuel tank. When the engine is stopped, a scan tool in the output controls function can turn ON the fuel pump


  6. #6

    Default This answer fixed my truck

    Quote Originally Posted by dugy40 View Post
    I have a 5.3 engine and its gettin no fuel, Checked all fuses and relays and beleive to all be good.I tested them by changing out the relay with another one beside it since there the same and all the fuses are good, now I ordered a pump off ebay brand new,but it didnt come with a black module on top of pump,just a hole for my old one,i think its called a pressure switch or pressure sensor,I am not gettin fuel still,I dont hear a noise inside fuel tank. i tested old pump by hooking wires straight to battery and it works, so what can be wrong,can it be the pressure switch since it my old one? Is this what its called? or is there something else i should be checking, thank you in advance Doug


    This answer fixed my problem----->
    Hello, the pcm powers the fuel pump relay, thus powering the fuel pump. have you checked the ecm b fuse 20 amp. this fuse is power for one side of the relay, then the pcm powers the control circuit of the relay. the relay also has one ground. in order for a relay to work, you must have one power feed, one ground circuit, and one control circuit. in your case the pcm.
    the ecm b fuse is in the underhood fuse block!!!



    It was my ecm b fuse,didnt know to check this one,i am puttin more infor here,thanks everyone---->>>
    When the ignition switch
    is ON, the PCM activates the in-tank fuel pump. The fuel pump remains ON as long as the PCM receives reference pulses from the ignition system. If there are no reference pulses, the PCM turns the fuel pump OFF after about 2-3 seconds. The pump delivers fuel to the fuel rail and injectors, then to the pressure regulator, where the system pressure remains at 379-427 kPa (55-62 psi) while the fuel pump is running. Excess fuel returns to the fuel tank. When the engine is stopped, a scan tool in the output controls function can turn ON the fuel pump

  7. #7

    Default

    I had a similar problem and similar solution as above:
    Update. I had the battery disconnected from last night. (i was having a security light flashing and thought this could be a passlock issue) I was careful to reconnect tonight and my security light went away. So I eliminated that possibility and moved to the next...the ignition switch. I pulled apart the column and looked around, but found no corrosion. Still not getting power to the fuel pump relay. Got in bed to continue google searching and came across someone who had a bad ecm b 20amp fuse in the underhood area. Checked mine and it looked ok. Started checking all fuses that surround the fuel pump relay and many more. Found 2 bad fuses. CHanged them and VIOLA!!!!
    Hope it could be as easy for some of you also experiencing this issue.

Similar Threads

  1. Windshield Washer Pump not working (not the pump)
    By vdubn in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 11-20-2010, 09:39 PM
  2. 1999 Tahoe Z71 - what fuel pump do i have?
    By UC35TECH in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 2
    Last: 03-23-2010, 06:05 PM
  3. 99 silverado,fuel pump not working
    By dugy40 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 01-28-2010, 09:26 PM
  4. 00 chevy bad fuel pump
    By edean37 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last: 10-28-2009, 12:03 PM
  5. 1984 Chevy C20 Fuel Pump
    By 84ChevyC20 in forum Chevy C/K Truck Forum
    Replies: 2
    Last: 05-01-2009, 05:00 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •