GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default Low Coolant Message

    I have an 03 Silverado and every once in a while i get a low coolant level light and then it goes away quickly. I am trying to diagnose the problem, any ideas?
    2003 Chevy Silverado 4.3 V6 5-speed- Victory Red - Gibson Dual Sport Exhaust, K&N Intake, Goodyear Wrangler Silent Armors 265/75/R16 :great:

  2. #2

    Default

    i have no idea, but that happened to me on my 01 once over the summer. I had just driven it 350km, and when i stopped, the light came on. I turned it off, started it again, and it was fine. My coolant level was fine, the only leak I had developed after that, and there was nothing else out of the ordinary. I took it to a mechanic that my aunt and uncle use (I was visiting them), and he could not find anything. It has not happened since for me, but I still have no idea what would have caused it.

    2008 FORD F350. My new all-around truck.
    2001 Silverado Reg. Cab Not-So-Base -- SOLD
    2003 Avalanche Z71. No Cladding. Check out my Mod thread. - Crashed. Will be rebuilt soon.
    1974 Triumph Spitfire 1500 - Work in Progress
    2003 Sierra 3500 Duramax. The Newer, Better Work Truck -- FOR SALE


  3. #3
    Jr. Apprentice
    Join Date
    Jan 2010
    Location
    Baytown, Texas
    Posts
    18

    Default

    On my 2002 that happend to me and what had happened was that the coolent was right at the line and then when I was on a road that had a good "lean" to it the light came on. I pulled off to check it and ith level was good. Started the truck and the light went off. Got back on the road and the light came on. It was because of the drastic lean on the highway. I added a toch more coolant to it and that was the fix.

  4. #4

    Default

    Alright cool, thanks

  5. #5

    Default

    On my 2002 that happend to me and what had happened was that the coolent was right at the line and then when I was on a road that had a good "lean" to it the light came on. I pulled off to check it and ith level was good. Started the truck and the light went off. Got back on the road and the light came on. It was because of the drastic lean on the highway. I added a toch more coolant to it and that was the fix.
    Thats good that that was the fix for you. I was on a flat road, parked, and with the coolant well above the line. Mine might have just been some random glitch or something, too....

    EDITED - maybe i should quote the right post, instead of my own.
    Last edited by pmf608; 02-09-2010 at 11:41 PM.

Similar Threads

  1. Service 4WD Message
    By Six point in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 09-09-2011, 08:47 AM
  2. new and wishing welcome message would go away
    By badfish in forum Member Introductions
    Replies: 5
    Last: 10-01-2009, 10:52 PM
  3. Intro Message
    By bhbingle in forum Member Introductions
    Replies: 17
    Last: 09-07-2009, 11:51 PM
  4. low coolant light comes on and the coolant level is good...
    By kukini808 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 05-14-2009, 07:31 AM
  5. Suburban Message Center: Low Coolant
    By BurtsBurb in forum General Chevy & GM Tech Questions
    Replies: 9
    Last: 02-16-2009, 10:15 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •