GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9

Thread: p0300 code?

  1. #1

    Default p0300 code?

    Ok so yesterday night i got in my truck and fired it up and the check engine light started flashing, I back the truck up and drove to the end of the drive way and it was gone. So i drove it about 30 miles never had a problem one and it never came back on. well this morning i got up and started the truck up to go to work it was back on, but not flashing this time.(it was 15 degree f this morning) so i drove it to work then to the parts house on break and they told me it was p0300 multiple ramdon clyinder misfire. she cleared the code and i havent left work yet so idk if its back on or not. I was woundering if anyone could point me in the right direction. p.s the truck is running fine, nothing feel differnt at all. thanks
    03 silverado ls model x-cab z71 w/ 5.3l.
    black lo pro toolbox
    ruff country leveling kit
    285/70/17 tera tracs
    stock 17's that are rhino lined
    5% tint

  2. #2

    Default

    Quote Originally Posted by dshewy14 View Post
    Ok so yesterday night i got in my truck and fired it up and the check engine light started flashing, I back the truck up and drove to the end of the drive way and it was gone. So i drove it about 30 miles never had a problem one and it never came back on. well this morning i got up and started the truck up to go to work it was back on, but not flashing this time.(it was 15 degree f this morning) so i drove it to work then to the parts house on break and they told me it was p0300 multiple ramdon clyinder misfire. she cleared the code and i havent left work yet so idk if its back on or not. I was woundering if anyone could point me in the right direction. p.s the truck is running fine, nothing feel differnt at all. thanks
    Found this on a search for the code. It also has some thing to look at. Hope it will help!!


    P0300 - Check Engine Light Diagnostic Trouble Code Description
    Paul


  3. #3

    Default

    thanks for the infor kinda puts me in the right direction, but i dont believe it had anything to do with my fuel system bc its not actually missing at all.
    03 silverado ls model x-cab z71 w/ 5.3l.
    black lo pro toolbox
    ruff country leveling kit
    285/70/17 tera tracs
    stock 17's that are rhino lined
    5% tint

  4. #4

    Default

    Quote Originally Posted by dshewy14 View Post
    thanks for the infor kinda puts me in the right direction, but i dont believe it had anything to do with my fuel system bc its not actually missing at all.

    Dshewy, I hope it helps. Like that article said, and I always do, start with the basics and work your way up. I've found a spark plug wire on my brothers jeep last year, that had melted causing problems. It costs to dang much to have to take it in to be diagnosed and fixed. Keep us informed when you solve the problem. Good luck
    Paul


  5. #5

    Default

    alrite man will def. do bc ive been reading thread after thread and no one ever tells what they find out.i will let everyone know as soon as i get it figured out
    03 silverado ls model x-cab z71 w/ 5.3l.
    black lo pro toolbox
    ruff country leveling kit
    285/70/17 tera tracs
    stock 17's that are rhino lined
    5% tint

  6. #6

    Default

    anyone ??????
    03 silverado ls model x-cab z71 w/ 5.3l.
    black lo pro toolbox
    ruff country leveling kit
    285/70/17 tera tracs
    stock 17's that are rhino lined
    5% tint

  7. #7
    Sr. Apprentice
    Join Date
    Jul 2008
    Location
    Santa Clarita CA/ LA / So Cal
    Posts
    38

    Default

    I have a 2003 silverado 2500 I started getting this same code after i put in NON AC Delco plugs and NON ac delco wires, got summit brand 8mm wires, direct replacements , and bosch plugs., also got a rough idle with them. broke down and replaced wires and plugs with AC Delco and no more P300 random missfire code and no more rough idle, very strange but several people have said that AC delco works best
    Jason * So Cal

    2004 Silverado 2500HD 4x4 Crew cab LT2
    2004 Yamaha YZ450f Dirt Bike


  8. #8

    Default

    I was getting a PO300 in my 99 Sonoma along with a Crankshaft Position Sensor (the code # eludes me at the moment) Intermitent Signal Code.

    I had replaced the Crankshaft Position Sensor (CPS) just a year prior with a one from Autozone, so I returned it for a new one. Didn't help, one bit.

    Next I go through the normal list of things. Plugs, Wires, Cap, Rotor, Coil. Nothing.

    So I move on to some bigger items, including replacing my PCM and my Intake Gaskets. Still no change.

    By now the misfire has ruined my catalytic converter, so its rattling and sounding like Hell and my truck is really pissing me off.

    Out of desperation, I purchased yet another CPS. This time one from GM. BINGO! Haven't seen a misfire or CPS code since.

    I don't know if the magnet in the Autozone part wasn't up to snuff or what the deal was, but the CPS from the dealership was the most releaving $90 I've ever spent.

    I'm not sure if this helps, but I do know a PO300 is a very, VERY frustrating problem to trackdown. All the code is telling you is that your engine is misfiring and NOTHING else. ****ing aggrevating!

    I see the last post for this thread was February of this year, so I hope you've solved your problem by now. If not, good luck, man.
    Last edited by Mumbles; 04-13-2010 at 01:09 AM.
    99 GMC Sonoma HighRider M5
    99 Pontiac Firebird Formula M6
    97 S10 Blazer 4x4 A4

  9. #9

    Default

    there are several possible concerns your rig may be experiancing. throwing parts at it could get alot more expensive than a 70 dollar diag fee

    the most i see with those codes have dirty/clogged fuel injectors or intake ports. has he ever had injector/carbon clean? (not just adding the junk parts store "cleaners")

    check the fuel trim. could possable have intake gaskets leaking around the intake ports causing it to run lean

    check ground 103 its eather on the front or rear rh cylinder head. Any corrosion?

    monitor your h02's with a scan tool and see if one is acting funny
    GM TECH

    05 silverado shortbed

Similar Threads

  1. Code P0200 abd P0300
    By nickpatton_189 in forum Performance & Fuel
    Replies: 1
    Last Post: 06-30-2010, 11:13 PM
  2. 2001 Chevy Silverado 5.3 code P0300 help
    By 1quick6 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 06-28-2010, 05:09 PM
  3. need help P0300
    By cable734 in forum GM Powertrain
    Replies: 5
    Last Post: 03-05-2010, 12:51 AM
  4. P0300 Code
    By sociald in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 01-17-2009, 05:07 AM
  5. Code P0300
    By msm1889 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 04-10-2008, 07:52 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •