GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Question 2006 Colorado 2.8 Litre Randomly wont Crank

    Howdy folks.

    Your help is needed!

    I own a 2006 Chevy Colorado Extended Cab with the 2.8 Litre 4 Cylinder Engine & Manual Transmission with 41,000 miles.

    This Truck started about a year ago not cranking at random when it is at operating temperature. When it did this the 1st time the oil level was right at the ad mark, so I assumed that it apparently had a low oil level sensor but no light because upon adding oil it started right up. Now fast forward to about a month ago it hapened again, added oil no more problem. Now as of last week it has started doing this when the engine is both cold and hot and completely full of oil. Everytime though it will briefly crank once and then acts like it's either not getting fire or fuel one, but just figiured out today that if you let it set for 3 to 5 minutes that it will then fire right up.

  2. #2

    Default

    You might take it to a dealer/mechanic or one of the parts stores that will check for "error codes" that might give you a place to start. Sounds like a "sensor" might be at the root of it though. Good luck!


    2010 Z/71 Colorado C/C
    Black 4X4 w/5.3L V8
    ===============
    2007 Winnebago Adventurer
    w/8.1L Chevy & Allison 6spd.
    Canyon Lake, Texas

  3. #3

    Thumbs up

    Quote Originally Posted by retired2001 View Post
    You might take it to a dealer/mechanic or one of the parts stores that will check for "error codes" that might give you a place to start. Sounds like a "sensor" might be at the root of it though. Good luck!
    Thanks, I have a code reader and the dealers in this area manged to fix nothing while it was under warranty. It shows no codes.

    Guess i just need to buy an OEM Manual and start reading and testing.

  4. #4

    Default Starter

    hi sounds like you have a starter going bad. i hope not. they are a bear to change.

    http://s1191.photobucket.com/albums/z477/noell1947/pbr%20time/
    2004 Chevy Colorado 2wd/4l60e/3.5 Inline 5
    6-PIAA 520 series yellow ion spot lights 85 watts each
    PIAA quattro fog lights w/extreme white/yellow ion bulbs
    Anzo projector headlights/LED turn signals
    LED underbodys 7-color/LED interior lighting
    JET stage 2 performance chip/Magnaflow exhaust S/S
    Recon Big Rig Lights/LED tail lights/3rd brake light
    Putco LED bed lights/BEDRUG
    Goodmark 2" rise Cowl hood/K&N fipk intake
    98-04' Blazer overhead console & floor console
    40/60/40 seat modified to 40/console/40
    33" Cooper Discovery A/T
    16" Pro Comp extreme alloy wheels

  5. #5

    Thumbs up

    Quote Originally Posted by seffieldvillage@aol.com View Post
    hi sounds like you have a starter going bad. i hope not. they are a bear to change.
    Thanks, the starter works fine and turns the engine plenty fast enough that it should be cranking.

    It's like it either isn't getting any fire or that it isn't getting fuel.

  6. #6

    Default

    Relpace your relays. Mone did the same and I purchased new ones and they have a newer type.

Similar Threads

  1. Chevrolet : Colorado 2006 CHEVROLET COLORADO REFRIGERATED TRUCK
    By ChevyFan in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last: 07-28-2010, 04:00 PM
  2. Wont crank.
    By Santoy956 in forum GM Powertrain
    Replies: 3
    Last: 06-15-2010, 10:56 PM
  3. Replies: 0
    Last: 06-19-2009, 06:00 PM
  4. 2006 silverado ignition wont switch wont turn
    By cgcomeaux123 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 5
    Last: 12-01-2008, 04:05 AM
  5. 97 Burb wont start - Heavy Crank
    By chargerrich in forum GM Powertrain
    Replies: 3
    Last: 03-02-2008, 08:52 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •