GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default Front heat/ac blower fan question

    Hey everyone,,
    My heat/ac blower fan only wants to work intermittently.
    (1995 Burban 1500 4wd)

    It's just a crapshoot if it will work or not.

    It does heat,,I can get hot air out when in motion just from air pressure,but the fan wont kick on.

    The rear fan works just fine.

    I may have done a horrible job of describing this,,but does anybody have any ideas/suggestions?

    Any and all help is greatly appreciated.
    Thanks,,Randy

  2. #2
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default Troubleshooting 101

    First you have to determine if it is a fuse, switch, the blower motor. Check the fuse panel for any blown fuses, then the next step would be to check if power is getting all the way to the fan motor. On the rightside of the footwell there is an insulated rubber cover over the fan motor housing. You don't have to remove the cover. With a flashlight if you look toward the top of the fan motor housing you will see two wires. Mine are color coded purple (on the left) and black (right). With the engine running, I measured the following voltages: 6vdc to 13.5vdc on the purple wire and 0.0vdc - 0.8vdc on the black wire. The voltage varies on the position of the fan speed switch. I don't know what is factory spec for these test points, use mine for reference only. If your voltages are similar, then I would suspect the blower motor, if no voltage is present I would expect the problem to be back towards the switch. The switch is part of a fan/ac control module and has to be replaced as a unit on the 93 burb, I don't know if the 95 is different. If you want more info on the fan motor swap check out my earlier post at: http://www.gmtruckclub.com/forum/showthread.php?t=3399
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

  3. #3

    Default

    Thanks again for the advice..

    Checked it out today...Fuses are all okay.

    When I started messing with the blower fan,it started working.
    Whenever I turn off the truck and start it again,,it wont work....jiggle the blower "housing" and it starts working again.

    Now my problem is this..the black plastic housing for the blower motor is falling apart. The plastic is very,well,I guess worn,,and it pretty much will just break and peel off in my hands.

    (I'm not some gorilla,,I'm not being rough with it)

    I've looked at a couple of sites selling blower motors,,but they dont look like they include the housing.
    And..it seems like the fan works fine,,it's just the housing messing everything up.

    Any suggestions?

  4. #4

    Default

    I have a 1990 Suburban with 4WD with the exact same thing happenning. Yesterday morning, I drove to work (13 miles) and the fan did not come on at all. The frost was melting off the window because the heat was getting to the window.

    When I started the vehicle again, the fan came on after about 10 seconds. I thought this was strange.
    1990 Chevy Suburban (4WD)

  5. #5
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    Some of these fans stop working because of the carbon build up from the brushes. Or it could also be that the brushes are worn to their limits.
    Patrick
    Rhode Island


  6. #6

    Default

    Where would the heater fan on a 1990 Burban be located? Can I get to it without having to rip out my dash?
    1990 Chevy Suburban (4WD)

  7. #7
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    From what I'm seeing your fan would be in the same location. Passenger side under the dash. You should see a large round black cover. You probably will have to disassemble part of the dash, not all of it to get it out.
    Patrick
    Rhode Island


  8. #8
    Sr. Apprentice
    Join Date
    Oct 2007
    Location
    Houston, TX
    Posts
    31

    Default

    I have a 1990 2WD R1500 GMC Suburban, and the blower motor is in the engine compartment, on the firewall on the passenger side. It is held in by, I believe, something like 5 screws. I have replaced it ~4 times during the last 12 years of owning the Suburban. I believe AutoZone sells these motors for under $20.00, and offers a lifetime warranty, so when it goes out, just take it down to AutoZone and they'll give you another one.
    1990 GMC Suburban 329,000 miles

  9. #9
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default

    Here is the post describing how I changed the blower motor on my 93 burb. Yours may be different.
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

Similar Threads

  1. my blower for heat wont work
    By 1995z71 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 09-13-2009, 05:01 PM
  2. No heat up front, but heat in rear on '83 'burb
    By FUNFINDER in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 9
    Last Post: 04-20-2009, 02:50 PM
  3. air/heat blower not working?
    By gabronco91 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last Post: 12-14-2008, 01:13 AM
  4. BLOWER CONTROLS, FRONT & REAR [Expired Topic]
    By IBNobody in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 01-16-2006, 01:37 PM
  5. A/C Heat Blower Noise
    By THECHIN29 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 2
    Last Post: 12-14-2005, 01:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •