GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 8.1 gmc throwing code after hard acceleration?

    It's 2002 and just had CAI installed and now under heavy acceleration I throw a light. After I park the truck for s bit it turns off and is fine I cant feel any differenceat all. Not sure what's going on. any ideas?

  2. #2
    Sr. Mechanic sc99z71's Avatar
    Join Date
    Feb 2007
    Location
    Moncks Corner, SC
    Posts
    160

    Default

    Could be getting a lean condition at heavy acceleration dut to the increased amount of air now entering because of the CAI.
    99 Silverado 1500 Z71
    5.3L 4L60E Tranny
    TransGo Shift Kit
    2.5" Rough Country
    Suspension Lift
    33" BF Good A/T
    Cherry Bomb Turbo
    Cobra CB w/
    Dual Fiberglass Antennas

    01 Kawasaki KLR650

  3. #3
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,356

    Default

    Did you disconnect the battery for ten minutes after you put the CAI in?
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  4. #4

    Cool 8.1 gmc throwing code after hard acceleration?

    Check for air leaks, retighten the cai clamps.

  5. #5

    Default

    did not dis connect the battery after the install. if its throwing a lean code after heavy acceleration, is there a fix for this ?

Similar Threads

  1. 97 Sub, 5.7 vortec, hard starts, very rich, code P0134
    By lexisdad1201 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last Post: 03-23-2010, 07:29 AM
  2. obd2 codes throwing me off
    By greasemonkey in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 02-28-2010, 01:46 PM
  3. My '87 GMC is throwing a code
    By MD4x4 Fireman in forum General Chevy & GM Tech Questions
    Replies: 7
    Last Post: 12-22-2008, 03:27 AM
  4. My Cavalier is throwing P0440
    By Steve in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 03-01-2008, 06:36 PM
  5. My friends trucks throwing a code
    By MD4x4 Fireman in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 01-17-2008, 07:04 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •