GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default Sierra transmission acting strange

    So I have a 1999 Sierra 5.3, I had the transmission rebuilt in October. Last week I was driving and lost all gears, no slipping, just like the truck was in neutral. I get the truck towed home, all of a sudden I have a transmission again. I am able to drive about 2 miles and I loose everything again, shut the truck off, restart a few minutes later and the transmission shifts fine again and then the cycle starts over. Anyone have any ideas on what the problem may be?

  2. #2

    Default

    Need to get it scanned for codes......
    Joseph


    Airforce Veteran (7 years)


    NRA Life Member

  3. #3

    Default

    I am waiting a few days to get a Tech II scanner. Just looking for some ideas before then.

  4. #4
    Sr. Mechanic Gambit's Avatar
    Join Date
    Feb 2010
    Location
    VA Beach for now
    Posts
    189

    Default

    sounds like maybe your linkage wasnt adjusted properly? If it feels like it is slipping into neutral it probably is. Did you get a warrentee on the rebuilt tranny?

    When it loses drivability is it after going over a bump or something? That could lean even more towards the linkage not being adjusted properly. next time it happens throw the gear selector in neutral and pop it back to drive see what happens or go for the lower gear selections.
    Last edited by Gambit; 02-25-2010 at 08:24 AM.
    Jeep Recovery Vehicle.

  5. #5

    Default

    Quote Originally Posted by Gambit View Post
    sounds like maybe your linkage wasnt adjusted properly? If it feels like it is slipping into neutral it probably is. Did you get a warrentee on the rebuilt tranny?

    When it loses drivability is it after going over a bump or something? That could lean even more towards the linkage not being adjusted properly. next time it happens throw the gear selector in neutral and pop it back to drive see what happens or go for the lower gear selections.
    I have a warantee on it. The truck is currently with the rebuilder. The problem just happened and the truck is basically undrivable now, There is no pattern as to when it happens, just seems to after about 2 miles. You can shift the lever and it won't go in any gear. You shut the truck down for about 2 minutes and you are good to go another mile or two (shifts just fine in that time frame)

  6. #6
    Sr. Mechanic Gambit's Avatar
    Join Date
    Feb 2010
    Location
    VA Beach for now
    Posts
    189

    Default

    You gotta love electronic transmissions.

  7. #7

    Default

    Quote Originally Posted by Gambit View Post
    You gotta love electronic transmissions.

    ..or not. Hopefully I will get it figured out soon. Had to buy a Cavalier Z24 to get me around until I get my truck back.

Similar Threads

  1. gauges acting up
    By jtw79 in forum General Chevy & GM Tech Questions
    Replies: 11
    Last: 08-15-2010, 08:10 PM
  2. abs acting weird
    By 98Z713dr in forum Lifted & Offroad Suspension
    Replies: 12
    Last: 06-14-2010, 06:30 AM
  3. 1990 GMC Sierra Transmission
    By Crawdaddy in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 14
    Last: 05-10-2010, 03:40 PM
  4. tbi spacer acting up!?!?!?!
    By rackchaser71 in forum Performance & Fuel
    Replies: 4
    Last: 04-29-2010, 11:22 PM
  5. The odometer is acting strange [Expired Topic]
    By Davandy in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 07-03-2006, 02:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •