GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Question 1999 Chevy Suburban with daylight running light dead and clicking noise from under

    I have a 1999 Suburban 107,000 miles. At first the daylight running light stopped working. When I turn on the light it works fine. Then soon after that hear all the clicking down under the steering column. I removed the relay the clicking stopped but the turn signal and hazard light do not work. While under the dash I noticed the air conditioner vent's servo that directs the air flow to the legs or face was moving by its self randomly. I think I have a electric short or interference but where?

    Thanks in advance.
    Simon

  2. #2
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    Quote Originally Posted by Simon.007 View Post
    I have a 1999 Suburban 107,000 miles. At first the daylight running light stopped working. When I turn on the light it works fine. Then soon after that hear all the clicking down under the steering column. I removed the relay the clicking stopped but the turn signal and hazard light do not work. While under the dash I noticed the air conditioner vent's servo that directs the air flow to the legs or face was moving by its self randomly. I think I have a electric short or interference but where?

    Thanks in advance.
    Simon
    That's a little creepy. I think I'd be weirded out if I saw the vent controller moving back and forth by itself, for no good reason.
    You gotta nip that gremlin in the bud quick, before it spreads to the rest of the vehicle.

    I would agree with the short, but tracking them down, can be both difficult, and time consuming. It could also be the charging system.

    If your alt is not putting enough back in, the vehicle is going to act up. I had a similar situation with a grand am. gauges would go nuts, doors would lock, and unlock while driving, and interior lights would come on and off. Replaced the alt, and it was fine.
    Patrick
    Rhode Island


  3. #3

    Default

    I also noticed that the clicking was still occuring while the engine was off, so the charging system was not effecting it. Maybe I should remove one fuse at time from the 3 fuse boxes and see what happens each time?

    Thanks!
    Simon

  4. #4
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    Quote Originally Posted by Simon.007 View Post
    I also noticed that the clicking was still occuring while the engine was off, so the charging system was not effecting it. Maybe I should remove one fuse at time from the 3 fuse boxes and see what happens each time?

    Thanks!
    Simon
    Couldn't hurt. Good luck, and let us know what you find out.

  5. #5

    Default

    I had experieced issues like that before as well. In my old '62, the problem was a leak in a rubber grommet that allowed water to get into the fuse box! I opened the hood once when it was raining and the truck started to turn over!!!!!

    It looks like you've got a small list of things to get checked out before you really want to start tracking down a short. I'd feel better if I got the ALT looked at and made certain that I had enough juice to keep it all running. Then I'd move to looking for shorts.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

  6. #6

    Default

    Quote Originally Posted by TrailLeadr View Post
    Couldn't hurt. Good luck, and let us know what you find out.
    Ok the problem was with the multi controller module which shorted and caused the vents and clicking noise. :( Spent $800 at Chevy dealer! Ouch! And also replace the front day running lights diode..... Wow!


    Simon

  7. #7
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    Quote Originally Posted by Simon.007 View Post
    Ok the problem was with the multi controller module which shorted and caused the vents and clicking noise. :( Spent $800 at Chevy dealer! Ouch! And also replace the front day running lights diode..... Wow!


    Simon
    Wow, that's pretty pricey, but it doesn't sound like there was a way around it.

  8. #8
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default

    Quote Originally Posted by TrailLeadr View Post
    Wow, that's pretty pricey, but it doesn't sound like there was a way around it.
    Could have traded straight across for a beauty like this. Guaranteed not to have a $800 control module.
    1946 Suburban
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

  9. #9

    Default

    Quote Originally Posted by unplugged View Post
    Could have traded straight across for a beauty like this. Guaranteed not to have a $800 control module.
    1946 Suburban
    Makes me drool...

Similar Threads

  1. 1999 suburban daytime running lights question
    By ochs99 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last: 04-15-2010, 06:44 PM
  2. 1999 Suburban Running Lights
    By hac20853 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 04-13-2008, 11:54 PM
  3. Ac Clicking Noise
    By Tamalero in forum GM Powertrain
    Replies: 2
    Last: 08-18-2007, 07:19 PM
  4. Ac Clicking Noise
    By Tamalero in forum Member Introductions
    Replies: 1
    Last: 08-10-2007, 07:36 AM
  5. Clicking noise from front hub. [Expired Topic]
    By ashndon in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 08-26-2006, 11:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •