GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Question service stabilitrak after lift blocks in back

    2010 Silverado 1500 LTZ Z71 4X4.Just under 200 miles on the truck. I had a leveling kit put in the front last week with no issues. This week the shop got in the blocks and ubolts for the back to put it back to the stock rake. 2 inch block. While driving home from the shop all of a sudden the message comes on " Service stabiltrak" and now alternates with "service traction control" I didn't have any issues before the blocks were put in the back. I have a friend who has a 2009 with the same setup and has no messages. Any ideas as to what might have caused this would be welcome. It takes a little driving before the messages start. I know if I take it back to the dealer they will say it is not covered under warranty because of the lift kit.
    Thanks in advance.

    Just hanging

  2. #2

    Default

    The good news is that if ether of those lights are on the other one will come on. I would get under the truck and see if they left anything unhooked for the ABS system in the back.

  3. #3

    Default

    Thanks, just crawled out from under there and everything looks to be hooked up where it's supposed to be.

    Hmmmmmm, removed the 2 inch blocks from the back, still got the leveling kit in front and now no more issues with service stabilitrak and traction control. Now it's level, weird how taking it back from the stock rake to level stopped the messages.
    Last edited by fornik8her; 03-01-2010 at 12:59 PM.

Similar Threads

  1. rear lift blocks....
    By DSpivey in forum Lifted & Offroad Suspension
    Replies: 2
    Last Post: 03-13-2010, 02:50 PM
  2. Which Rear Lift Blocks for '09 Silverado?
    By ride250s in forum Lifted & Offroad Suspension
    Replies: 6
    Last Post: 02-17-2010, 06:53 PM
  3. stock lift blocks
    By coombia21 in forum Lifted & Offroad Suspension
    Replies: 3
    Last Post: 08-27-2009, 11:10 PM
  4. Lift kit with stabilitrak?
    By Greg84 in forum Lifted & Offroad Suspension
    Replies: 2
    Last Post: 08-10-2009, 09:04 AM
  5. add a leafs or rear lift blocks
    By 520operator in forum Lifted & Offroad Suspension
    Replies: 7
    Last Post: 05-12-2009, 11:32 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •