GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Angry silverado 1500 cruise control problem

    ok so...i went ice fishing the other day and was driving in about a foot of snow on the ice. i got back out on the high way and try to set my cruise and it didn't work. i pressed it repeated times and it would flash on quick than go off right away... can anyone tell me whats going on. could it be frozen if thats even possible?

  2. #2
    Jr. Engineer lsutoms's Avatar
    Join Date
    Sep 2009
    Location
    baton rouge louisiana
    Posts
    281

    Default

    were you sliding on the road? i dont live in snow but if it doesnt have a problem and still does this my guess would be its noticing your sliding and won't turn on..... just a guess buddy lol
    "I'll Sleep When I Die"



    2009 Chevy Silverado LT1
    295/70/17 Toyo MT's
    2" rough country leveling kit
    CAI
    magnaflow exhaust
    custom tune
    spray in Line-X bedliner
    deep low profile took box
    6000K HID's
    5% + 20% tint on door windows and rear + layer of 10% rear glass and 5% tint strip
    2 12" Kicker CVT's
    custom sub boxes
    1000 watt hifonics sub amp
    4 6.5" hifonics door speakers
    4 hifonics tweeters
    320 watt hifonics amp
    Quad bell train horn
    5 gallon air tank with 100% duty Viar compressor
    galls street thunder deluxe siren/PA

  3. #3

    Default

    no i wasnt slidin. most if the snow has melted on the roads where i am

  4. #4
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default

    Check the brake light bulbs, and otherwise it could be a stuck/defective stoplight switch. I had a situation where everytime I turned on the right signal, the truck would drop out of cruise. If the right signal was on, the cruise would not engage. Not affected when the left signal was on. The right rear bulb had burned out. I replaced the bulb and the cruise control resumed normal operation.
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

  5. #5
    Master Mechanic SupplySgt's Avatar
    Join Date
    Feb 2010
    Location
    Middle TN, displaced Okie
    Posts
    764

    Default

    I'd check the brake light switch by the brake pedal. if it's not that then it's probably the cruise control module. module went out on my 96 when I had it and I went junkyard prowling and got one dirt cheap (like $25 but that was 3 years ago). Check the brake light switch first and then test the cruise module itself.
    93 Suburban (Southern Slayer): TBI 350, 4L60E
    73 Z28 Camaro: L82, TKO 600

    KJ4CLI



    "...Death smiles at us all, all a man can do is smile back..."

Similar Threads

  1. cruise control issue 2010 silverado
    By busman442 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 05-30-2010, 05:47 AM
  2. 99 silverado 2500 cruise control parts
    By ChevyFan in forum Chevy Parts eBay
    Replies: 0
    Last: 02-01-2010, 01:50 PM
  3. 2008 Silverado sloppy cruise control
    By n6vig in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 11-30-2009, 06:05 PM
  4. 99 Silverado Cruise control problems
    By jhampsilverado in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last: 01-23-2009, 09:12 PM
  5. '08 silverado cruise control add- on
    By brianmerriam in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 12-13-2008, 07:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •