GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default ignition troubleshooting

    Hello, I'm a new member with a basic question. 98 sierra vortec v-6 won't start. Sat for a few days in pouring rain without being run, cranks fine but won't fire. Was running fine when I parked it. Checked cap, rotor, plug wires all are not very old, looked good except found some corrosion on coil wire terminals. Cleaned up, still nothing. Tested for spark at plug with in-line spark tester, very weak spark. Checked for spark at plug in open air with screwdriver, also weak spark. Tested coil with ohm meter as instructed in Chilton book, checks ok. Fuses for Eng 1 and ECM 1 ok. What is the module on the side of the coil bracket? It looks like it may serve as a condenser would in an old-style system. Anyone have any suggestions?

  2. #2

    Default

    i believe that thing on the side is your icm (ignition control module)

  3. #3

    Default thanks

    Thanks. The parts store guy insists I should try cap and rotor first but they look brand new and show infinite resistance between cap terminals. I think I will find a module I can try from a buddy's truck to rule that out. I hate throwing $$$ at the problem to find the answer, especially since I'm laid off and $ are scarce.

Similar Threads

  1. Brake Light Troubleshooting
    By Sonnuvah in forum Lifted & Offroad Suspension
    Replies: 2
    Last Post: 11-23-2009, 01:57 PM
  2. Troubleshooting a P0307 code
    By hblock72 in forum GM Powertrain
    Replies: 2
    Last Post: 10-27-2009, 06:29 AM
  3. Need Help Troubleshooting AC Problem [Expired Topic]
    By briancastellanos in forum Chevy Equinox Forum (GMC Terrain)
    Replies: 0
    Last Post: 08-04-2008, 03:16 AM
  4. Misfiring troubleshooting, 86 k10 4x4 silverado 305
    By Daniel in forum Chevy C/K Truck Forum
    Replies: 3
    Last Post: 05-29-2008, 10:23 PM
  5. troubleshooting windshield washer pump
    By heftylefty58 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 13
    Last Post: 12-06-2007, 01:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •