GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Unhappy 96 GMC Truck-Heater only blows on high

    I am having a problem with my 96 GMC Sierra 1500 Truck. The heater would only blow on high for the last couple of months, but now doesn't work at all. What could it be? Also the window washer fluid wont spray out and hasn't for about 2 years now. Any help would be greatly appreciated. Thanks

  2. #2
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default

    to GMTC. A great place to hang out for all things GM.

    First search the GMTC forums for "blower relay" That should get you the answer you need. Somewhere I posted some pics of the area behind the glove box where the relays are.

    As far as the washer. Test the pump and if the pump is working check the hoses and check the nozzles. The nozzles are prone to clogging. Try soaking the nozzles in CLR to see if they will clear, otherwise replace any worn hoses and the nozzles.


    ==> New members please click here for tips to making your first few posts count! <==
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

  3. #3
    Jr. Apprentice SkiBurban's Avatar
    Join Date
    Sep 2008
    Location
    Northern California
    Posts
    13

    Default Plugged Washers

    The may be just gummed up with dried washer fluid. I used a small paper clip to slid a short distance into the sprayer head, then disconnected the hose at the pump. Next I used an air compressor to blow air backwards and the gunk out of the line. If you do this, make sure there is not a check or 1-way valve in the system, because the air compressor trick won't work.
    Good Luck,
    Paul
    2005 K1500 Suburban LT 50K miles - All Stock

    1992 K2500 Suburban 200K miles - Still Running:rofl:

  4. #4

    Default

    I had the blower problem with my 96 Suburban. Turned out to be the blower motor resistor. Kind of hard to get to but an inexpensive part.

  5. #5
    Jr. Engineer
    Join Date
    Mar 2010
    Location
    Cochrane, AB
    Posts
    231

    Default

    Had the same issue on an Acura integra... Blower Motor Resistor... it is a cheap part, and hopefully it's just that and the the blower motor itself - those are expensive
    SEAFOAM, I PUT THAT @#!$ IN EVERYTHING!



    2004 Silverado LS 5.3L Z71 Crew Cab
    260,000+ km

Similar Threads

  1. Chevrolet : S-10 HIGH PERFORMANCE TRUCK
    By ChevyFan in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last: 07-23-2010, 08:00 AM
  2. 2004 Silverado AC only blows on high
    By TELORVEHC in forum GM Electrical Tech
    Replies: 7
    Last: 05-05-2010, 08:37 AM
  3. Heater blows cold
    By Beer Belly in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 12-27-2009, 07:24 PM
  4. Replies: 0
    Last: 12-14-2009, 04:50 PM
  5. Truck Overheats & Heater doesn't heat up & AC doesn't get very cold
    By porterusaf in forum General Chevy & GM Tech Questions
    Replies: 9
    Last: 05-04-2009, 10:22 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •