GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11

    Default Encoder Motor filling with oil

    Morgan and Darress (and anyone else with this problem):

    I have a 2004 Suburban 1500 w/ 156,000 miles that I bought used a few months back, with an NVG 246 Transfer case (RPO code NP8). Since owning it, I have been getting intermittent Service 4WD messages as well as random shifts into 4LO on initial startup, no lights on the selector panel, and other annoying gremlins.

    To start with, I took it to the stealership to get the codes pulled with their GM Tech2 scanner, and they reported a C0306, C0321, C0327. They said I would need to replace the encoder motor sensor. Here's what the codes mean for everyone's reference:

    C0306: open or short to ground/short to voltage in Motor control A or B circuit
    C0321: no battery voltage at motor lock control prior to applying motor lock
    C0327: encoder sensor feedback range outside of 0.5-4.5V

    I am a DIY guy like all of you and my internet search led me to this forum. I took apart my encoder motor tonight using the excellent writeup that Morgan referenced. My intention was to just replace the sensor like the stealership suggested, but when I took the motor apart, I found that everything was submersed in Transfer Case Oil like Morgan and Darress had. These findings are definitely consistent with the symptoms I experienced as well as the codes that were reported. With all that oil shorting everything out it makes sense that I would have random shifts, random lights, and Service 4WD messages.

    I cleaned it all up, replaced the sensor, and put it back together and it works great now. My question is, did you guys ever figure out how to change the transfer case shifter shaft bearing (GM P/N 12547464)? For now, it is working great and I will just drive it as is, and maybe take the encoder motor apart every other oil change or something. I would really like to fix the leak though if anyone can give me some guidance.

    Here are some pictures of what I did tonight for those who want to see them.

    Encoder Motor initial inspection:

    Click image for larger version. 

Name:	Oil in encoder motor.jpg 
Views:	2211 
Size:	26.1 KB 
ID:	30483 Click image for larger version. 

Name:	Oil.jpg 
Views:	2124 
Size:	13.8 KB 
ID:	30486


    Encoder Motor Disassembled and Cleaned:

    Click image for larger version. 

Name:	Parts.jpg 
Views:	2468 
Size:	22.9 KB 
ID:	30484

    Encoder Motor Reassembled with new Sensor (GM P/N 88962315)

    Click image for larger version. 

Name:	cleaned and reassembled.jpg 
Views:	2527 
Size:	20.3 KB 
ID:	30482


    Shifter Shaft on Transfer Case, w/ Bearing in question:

    Click image for larger version. 

Name:	Shift shaft bearing.jpg 
Views:	2127 
Size:	14.0 KB 
ID:	30485

    Any guidance on replacing that bearing here would be greatly appreciated. Thanks for your help and feedback!

    -Denny Smith

  2. #12

    Default Transfer Case Encoder - Oil Leak

    This thread has been an excellent share of information, thanks guys for providing such great details.

    I have a 2003 GMC Sierra 1500 HD with a leaking transfer case near the encoder motor. I also get intermittent ďService 4WDĒ messages in the winter only. At any rate, Iím about to undertake the disassembly of my encoder next Monday to find out where the leak is coming from and to see if I can seal things up so that I donít run the transfer case dry. Like Denny, I too look forward for anyone sharing information on either replacing the bearing or better yet, confirming how to prevent these oil leaks.

    Iíll report back on my findings next week and will patiently wait for anyone who can some shed light on the root cause of these leaks.

    Pierre

  3. #13

    Default

    I finally took my encoder off today to see where the leak was coming from. To my surprise I found hidden behind the encoder motor my Transfer Case was corroded to a point where I had a 1/8Ē pin hole through the housing. It was quite obvious this was my problem so I didnít take the encoder apart as it appeared to be free of oil. I cleaned the corroded area with a wire brush and brake cleaner then proceeded to patch it up with JB Weld.


    Transfer case

    This isnít the same problem as what most have experienced on this thread but I thought I would report back on my findings.

  4. #14

    Default

    Denman,
    Hi, nice pic's on your post. It has been interesting to see that others have had the same "oil in the encoder motor housing" problem that I had. I went through a couple of encoder motor sensors when I was doing my repairs and kept having the same issues with the faulty shifting as you and others also noted. The original encoder motor position sensor disk had scratches in it (circuit board like area inside the round sensor itself) causing contact in the wrong position and throwing the same codes you got (the original post by Morgan spoke of this too). I never changed the transfer case seal that separates the transfer case lubricant from the encoder motor housing because at that point I wasn't sure that it was leaking from there (and I couldn't figure out if I could do it without taking the transfer case apart, which I really didn't want to do). Any way, the transfer case uses a special lubricant that is blue in color (Autotrac II), the stuff getting in my encoder motor housing was dark brownish like conventional gear oil. I decided to change the fluid before doing anything else with the encoder motor since what I was doing was not working, or not for very long any way. When I emptied the transfer case the oil was in fact like gear oil, probably changed by a lube shop when the original owner had the vehicle serviced (obviously the wrong stuff). I put the GM lube back in the transfer case and purchased a lifetime warranty encoder motor assembly from a local parts store chain so that I could swap it later if it failed again. I figured with my track record that it would happen again within 4-6 months. Well, it has been over a year and a good 13-15 thousand miles and it's still working like a charm. I believe in my case what may have been happening, just speculation here but it makes sense, is that the wrong fluid/viscosity could have caused the oil to be forced into the encoder motor housing through the shifter shaft input seal or bearing. The other possibility is that there was oil in the actual encoder motor mechanism itself that was leaking out and into the housing, but I don't really think that was it because the volume of oil that I found in the housing likely couldn't have fit in that small motor housing. I hope this info helps in your situation and that the oil doesn't leak back in like mine did. If it does, you will be taking it apart again soon. If you don't mind, let me know if your transfer case lubricant is the original type or if it has been replaced with another type. Just curious and if so it supports my theory.
    Thanks,
    Darress
    Last edited by darress; 10-18-2011 at 04:28 PM.

  5. #15

    Default

    That's an interesting theory Darress and may explain why I didn't appear to have any oil in my encoder motor assembly. My transfer case had and continues to have GM Auto Trak II (bleu) transfer case fluid.

    Pierre

  6. #16

    Default Transfer Case Fluid

    Darress:

    I have a sneaking suspicion that my transfer case has gear oil in it instead of the correct fluid. I think I will go ahead and drain the transfer case and refill it with the correct GM spec fluid. I will let you know what I find when I get around to doing this. Thanks for the feedback!

    -Dennis

  7. #17

    Default

    Hello! It looks like I will be digging into one of these and I'm thankful for the information here. I'm wondering if anyone has the P/N for the gasket listed. Also, I'm unclear if there is a shaft seal that needs to be replaced. From my understanding of recent posts, if the wrong oil is used, it may leak oil into the encoder housing, but the encoder can fail without oil in the housing.

    Lastly, is the oil a dealer only thing or does NAPA have the right stuff? I have become uncomfortable asking NAPA for advice on what oil to use and the dealer will probably tell me to only use their oil otherwise the transfer case will fail, the engine will seize up, my dog will get rabies and I'll get the Clap.

    Actually, I'm not going to ask for advice on the oil because I haven't searched yet, but ass soon as I hit Send, I'll start digging into that.

    Thanks for any help.

    Forgot to mention it's a 2007.

    Final edit:

    Since we have this encoder, I understand that it's an NV 246, so I need the AutotracII oil so dealer only. Do I have that right?
    Last edited by whitedog; 12-02-2011 at 11:46 AM.

  8. #18

    Default

    Whitedog,

    Hereís a link to the parts numbers http://gmfixit.com/service-4wd-trans...shows-neutral/

    I did not see a seal on the shifter shaft nor was I able to find anywhere on the internet someone changing one. Autotrak II is the oil you need and I have yet to find a substitute and based on everything Iíve read, I wouldnít bother taking a chance.

    Good luck!

    Pierre

  9. #19

    Default

    Thanks, Pierre. that link was exactly what I needed. I checked Rockauto and the prices were just a few dollars less than what we can get them for at the dealer. Anyway it's better to keep our money closer to home when it makes sense to.

    Ok, one fire is out, now it's back to the Subaru, Dodge and Chevy... Sigh...

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Encoder Motor Filling with Oil
    By Mtrotter in forum GM Powertrain
    Replies: 0
    Last: 05-10-2010, 05:59 PM
  2. Encoder sensor replacemente?
    By Mtrotter in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 03-04-2010, 01:45 PM
  3. Encoder Motor Replacement
    By Higgie in forum GM Powertrain
    Replies: 1
    Last: 11-25-2009, 07:40 PM
  4. Changing encoder motor on 98 Jimmy
    By otis24 in forum GM Powertrain
    Replies: 1
    Last: 11-01-2009, 10:59 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •