GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2

Thread: 83' K20 problem

  1. #1

    Default 83' K20 problem

    well, seems the K20 3/4 ton i have doesn't like driving fast anymore. after by passing the fuel line to the driver side fuel tank, fixing the front u-joints, and basic stuff ie oil. it'll get up to 30-40mph or so then just cough and quit, it'll die if i push it otherwise it just sputters until i slow down. i had accidentally taken the vacuum line off from the tranny to engine, but have since put it back. bear in mind the fuel tank has not been used in 4-5 yrs and i just bypassed the tank selector valve Replaced fuel filter, got new plugs wires and cap/rotor. waiting on a 6mo old Edelbrock Carb to replace old one.
    1983 Chevy Scottsdale 4x4 350cui snow plow

    OIF 2008-2009 Baghdad
    B Co 1-22INF 1BCT 4ID
    "Regulars By God"

    Infantry "Follow Me!"

  2. #2

    Default

    Welcome to the site!

    My first thought was the fuel filter, but you've covered that. The carb may be out of adjustment, or clogged internaly.
    Check your exhaust to see if the cat convertor is clogged up. I've seen plenty of 30mph vehicles find the benefit of a 3ft crow bar!

    Good luck,

    1999 Chevy K2500 Suburban 350
    K&N, reworked cai, Thrush cat-backs
    Vinyl, cranks, floor shift, and rear air!

Similar Threads

  1. ABS problem
    By FireRed in forum Lifted & Offroad Suspension
    Replies: 5
    Last Post: 01-09-2010, 09:57 AM
  2. 96 Chevy tahoe problem fuel problem? Need help ASAP!
    By Fear58 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 12-13-2009, 05:38 PM
  3. new here but have a problem
    By kjames323 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last Post: 10-06-2009, 07:41 PM
  4. A/C problem
    By mprodman in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 04-03-2009, 12:41 PM
  5. Problem with AC
    By 4runnerGuy in forum General Chevy & GM Tech Questions
    Replies: 9
    Last Post: 03-30-2009, 07:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •