GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default 1993 GMC Sierra K1500

    Last week I got a 1993 GMC Sierra K1500 with a 5.7L 350 and have been working of fixing it up for my daily driver and it seems to run OK till I start going up hills then it acts like it starving for air( no power )... I changed the air filter... Put in a K&N in... It helped it some but still doest run like it should.... The engine was replaced a before I got it and the replacement engine has only 46,000 miles on it... I checked the timing it was set right... It has a new cap and button and wires.... I put in new plugs... I checked all the vacuum lines and there connected right and none broken all the wiring seems fine.... The check engine light is on and I get the code #35 ( idle air control sensor circuit fault ) would that cause this problem... Thanks...

  2. #2

    Default

    Anyone? LOL...
    My Toys
    1993 GMC Sierra K1500 4X4 5.7L 350
    1970 Triumph 650 Bonneville Chopper

  3. #3
    Jr. Apprentice
    Join Date
    Dec 2009
    Location
    calgary alberta
    Posts
    15

    Default

    im no expert but have you checked the catylittic converter it might be clogged?

  4. #4

    Default

    There is an IAC sensor mounted on the pass side of the TBI.

    $20 bucks to replace it, but you could remove it and clean it with TBI cleaner first to see if that would haelp.
    Pavement sucks... :grrrrrr:



    1994 K1500 4x4 Ext. Cab
    PCM chip and Xenon 8000k bulbs
    350cu.in bored over .050"
    balanced Crank, 10:1 compression
    Flat top pistons,cam,ported heads
    Option Racing Cold Air Intake
    Holley Throttle Body Spacer
    Accell Igition, 45kv coil
    FloTech Headers, no CATs, dual exhuast
    Goodyear Silent Armor A/T 305/70-16
    Pioneer SupertunerIII CD USB Bluetooth
    Kicker ZX200.2 ZX Amp
    Kicker Audio COMP 10" Subwoofer

  5. #5

    Default

    Quote Originally Posted by greenbastard View Post
    im no expert but have you checked the catylittic converter it might be clogged?
    None on it.... It has a test pipe on it which is fine by me....

    Quote Originally Posted by ejohnson03 View Post
    There is an IAC sensor mounted on the pass side of the TBI.

    $20 bucks to replace it, but you could remove it and clean it with TBI cleaner first to see if that would haelp.
    I will check it out and see it that fixes it....
    My Toys
    1993 GMC Sierra K1500 4X4 5.7L 350
    1970 Triumph 650 Bonneville Chopper

  6. #6

    Default

    Well I cleaned it up and seemed to idle smoother... I took the battery wire off to reset the computer and now I get a error code 43 and 34.....
    My Toys
    1993 GMC Sierra K1500 4X4 5.7L 350
    1970 Triumph 650 Bonneville Chopper

Similar Threads

  1. 1993 Silverado K1500 extended cab
    By MXZ1983 in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last Post: 03-14-2010, 09:42 AM
  2. 1993 Chevy K1500 stalls at idle
    By peedeeriverrat in forum GM Powertrain
    Replies: 2
    Last Post: 07-13-2009, 03:43 PM
  3. Removing front Differential 1993 K1500
    By remist17 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 06-24-2009, 09:14 AM
  4. 1993 k1500 transmission swap
    By okysmokey911 in forum Chevy C/K Truck Forum
    Replies: 5
    Last Post: 05-23-2009, 11:58 PM
  5. 1993 K1500 Suburban help
    By TheAngryHungarian in forum GM Powertrain
    Replies: 3
    Last Post: 10-25-2007, 10:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •