GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,386

    Default speed sensor or abs sensor

    My abs and brake light is on I crawled under there to look and the wire had been sliced and the plug and a few inches of wire was missing, my question is are the speed sensor and the abs light one in the same or two different sensors. I just got this truck so do not have a manual yet. 99 silverado reg cab
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  2. #2
    Sr. Apprentice BadBurban98's Avatar
    Join Date
    Mar 2010
    Location
    Long island New York
    Posts
    59

    Default

    wheres the broken wire the front or tranny or rear the brakes light is usually fluid or the parking brake is on the abs only will go on if the abs is malfunctioning
    Burnin' hard, loose, n', clean

  3. #3
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,386

    Default

    Its at the front left wheel

  4. #4
    Sr. Apprentice BadBurban98's Avatar
    Join Date
    Mar 2010
    Location
    Long island New York
    Posts
    59

    Default

    that will be your abs sensor in the hub that will cause that abs light to be on now where was it sliced the harness on the car or the harness before the plug on the sensor side?

  5. #5
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,386

    Default

    Thanks! Thats what I figured but you never know.

  6. #6
    Sr. Apprentice BadBurban98's Avatar
    Join Date
    Mar 2010
    Location
    Long island New York
    Posts
    59

    Default

    Notta problem bro

  7. #7
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,386

    Default

    So the actual brake light should just be for the fluid being low then?

  8. #8
    Sr. Apprentice BadBurban98's Avatar
    Join Date
    Mar 2010
    Location
    Long island New York
    Posts
    59

    Default

    yeah i'd check the fluid level and if its still on i'd check out the parking brake release switch

Similar Threads

  1. speed sensor cables
    By XS ive in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 06-24-2010, 05:46 PM
  2. 96 suburban speed sensor
    By kurtis48239 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 09-18-2008, 10:56 PM
  3. speed sensor
    By kurtis48239 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 09-03-2008, 01:00 PM
  4. Speed sensor
    By Jim Nolan in forum GM Powertrain
    Replies: 0
    Last: 02-26-2008, 11:07 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •