GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Chevy C5500 Kodiak Problem

    We have a Gulfstream MH on a 2004 Chevy C5500 chassis. When we were coming home from our trip last night at about 55 mph there was bump/surge from the motorhome and all the red panel lights lit up like it does when you turn on the key to start it. Then the panel lights all went off except two (the battery light and the airbag light). The engine remained running during all of this. We stopped and raised the hood, but there was no burning smell and I couldn't notice anything visibly wrong. Since we were only about 50 miles from home we decided to try to make it home, which we did. The two lights mentioned above stayed on the entire time. Thinking this might be an alternator problem I didn't turn the engine off until we got it parked at home. I was afraid it wouldn't restart if I turned it off.

    This morning I was able to start the motorhome with no problem with no red lights burning. I left it running for a while to see if the lights would come back on, but none did. If this is an alternator problem do you think it would have started this morning?

    Looking for help with this problem!

    Thanks, Carl

  2. #2

    Default

    Bumping this unanswered thread. Anyone have anything?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

  3. #3
    Master Mechanic bigdaddy77084's Avatar
    Join Date
    Jan 2010
    Location
    Houston, Texas, United States
    Posts
    649

    Default

    That big ol bus should run along time on battery power. How many battery does it have? It could be bad battery connections,starter connection,or the alternator. Good luck..
    95 tahoe 2dr 4x4 200,000+ miles

Similar Threads

  1. Chevy Kodiak Cab Lights Problem
    By garrett113 in forum Medium-duty Truck Forum
    Replies: 3
    Last: 05-24-2010, 10:37 AM
  2. Chevy Kodiak Forum
    By ChevyFan in forum Medium-duty Truck Forum
    Replies: 2
    Last: 05-18-2010, 05:05 PM
  3. kodiak 4500 fuel gauge problem
    By garrett113 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 04-30-2010, 05:18 PM
  4. Chevrolet c5500 2008 Chevy C5500 DUMP TRUCK
    By ChevyFan in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last: 01-06-2010, 09:30 AM
  5. 06 Chevy C5500 4x4 Bucket/Boom Truck
    By ChevyFan in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last: 11-22-2009, 12:40 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •