GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default tail light giving me grief

    My wife and I just purchased a 2005 Suburban this past week. I have found a few problems that for the most part have been able to fix thanks to this fourm, but I have a problem with the left rear tail light and one of the license plate lights are in-op. I can live with one light for the license plate but I have to get the tail lamp repaired. I removed the bulb which looks ok but I installed a new one anyway. Still no light. I checked for power with a vom and have only .3v. I checked the fuse and its good. I checked for power at the fuse and have 12v there. I checked the junction box at the right rear of the suburban where the wire harness connects and have only 8v there for the left tail lamp and 12v for the right. I replaced that junction box and still no luck. All the connectors that I removed from the junction box look good, but the 8v that I see at the j-box drops to .3v at the plug end that the left talilight harness plugs into. All the other lights work-brake,turn signal and reverse. Any help is greatly appreciated. The dealer where we got it from is not a chevy dealer and I fear they will just do a hack job to repair it.

  2. #2

    Default

    Seems like it is either a bad ground, or high resistance on some wires. Maybe try ohming out the wire from the junction block to the bad tail lamp? also, Is there any aftermarket harnesses, etc for trailer lights?

  3. #3

    Default

    Thanks for the reply. The truck has the factory tow package and the wiring appears to be loomed into the main harness. I will ohm out the wire to the lamp. I seen three ground wires at the left rear of the frame and I removed and cleaned them up. Are there any more that I should be looking for? I tried to see if there are any other breaks or connection points on the main harness that come out of the fuse panel under the hood to the rear of the truck where it plugs into that j-box but did not see any. Does anybody know if there is that I might be missing? Thanks.

    Brian

Similar Threads

  1. Tail light help
    By MossyOak3500 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 02-26-2010, 02:07 PM
  2. tail light
    By shadowt_t in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 0
    Last Post: 01-17-2010, 12:03 PM
  3. Tail Light
    By liquidcolombian in forum GM Electrical Tech
    Replies: 2
    Last Post: 01-13-2010, 09:49 AM
  4. New led tail light bar
    By justaphase44 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 01-17-2009, 10:00 AM
  5. Tail light and brake light recall
    By smiddy in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 12
    Last Post: 09-19-2005, 03:39 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •