GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Trouble code 16 - VSS Buffer

    I have a 1993 GMC Suburban. This morning when I started driving, my ABS light came on. The truck also would not shift out of second gea and the speedometer did not work. When I turned around to bring it back home, the CIL came on as well. When I pulled the codes I got code 16, which is the VSS Buffer. After searching through this forum, I decided that replacing the vehicle speed sensor would be a safe bet. So, I drove my truck in 2nd gear to the auto parts store and after about 10 minutes of driving it started shifting normally and the speedometer worked but nthe ABS light remained on. I went in a bought the VSS anyway and figured I would check for a loose wire or something and I would have the VSS just in case. On the way home, it drove perfectly and the CIL and the ABS lights were off. Got home and checked for a loose connection and everything looked great. Drove the truck again and the ABS light came on, it wouldn't shift out of second but the speedometer worked. After a few minutes, it shifted normal again and the ABS light remained on. My question is, could the VSS sensor have an intermittant problem? And, according to the Haynes manual, the VSS is in the transmission. I have a 4 wheel drive and the only thing I saw that looks like the VSS is in the transfer case. Is the VSS in the transfer case on 4 wheel drive trucks?


    Good things may come to those that wait, but only the things that are left by those that hustle.

    1993 GMC K1500 Suburban
    5.7 L V8 Engine

  2. #2

    Default

    Quote Originally Posted by artlock View Post
    I have a 1993 GMC Suburban. This morning when I started driving, my ABS light came on. The truck also would not shift out of second gea and the speedometer did not work. When I turned around to bring it back home, the CIL came on as well. When I pulled the codes I got code 16, which is the VSS Buffer. After searching through this forum, I decided that replacing the vehicle speed sensor would be a safe bet. So, I drove my truck in 2nd gear to the auto parts store and after about 10 minutes of driving it started shifting normally and the speedometer worked but nthe ABS light remained on. I went in a bought the VSS anyway and figured I would check for a loose wire or something and I would have the VSS just in case. On the way home, it drove perfectly and the CIL and the ABS lights were off. Got home and checked for a loose connection and everything looked great. Drove the truck again and the ABS light came on, it wouldn't shift out of second but the speedometer worked. After a few minutes, it shifted normal again and the ABS light remained on. My question is, could the VSS sensor have an intermittant problem? And, according to the Haynes manual, the VSS is in the transmission. I have a 4 wheel drive and the only thing I saw that looks like the VSS is in the transfer case. Is the VSS in the transfer case on 4 wheel drive trucks?
    You VSS is on the transfer case. I would pull it out and see if it has metal particulate stuck to the magnet. If so clean it off. If not you may have a broken wire or a buffer which GM calls a DRAC going bad.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  3. #3

    Default

    That was it! I removed the VSS and it had metal shavings stuck to it. I cleaned it of and reinstalled it and it works great! Thanks for the tip!


    Good things may come to those that wait, but only the things that are left by those that hustle.

    1993 GMC K1500 Suburban
    5.7 L V8 Engine

Similar Threads

  1. trouble code 171
    By snascar29 in forum Chevy Colorado Forum (GMC Canyon)
    Replies: 1
    Last Post: 12-10-2009, 06:38 PM
  2. trouble code
    By challutz in forum Chevy C/K Truck Forum
    Replies: 2
    Last Post: 11-21-2009, 07:37 AM
  3. Trouble code
    By T1743 in forum GM Diesel & DuraMax
    Replies: 1
    Last Post: 11-21-2009, 02:11 AM
  4. Trouble Code P0513
    By canislupis69 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 08-05-2009, 07:51 PM
  5. PO131 trouble code
    By johna20376 in forum Performance & Fuel
    Replies: 2
    Last Post: 05-26-2009, 12:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •