GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1
    Jr. Apprentice
    Join Date
    Aug 2009
    Location
    Coralville, Iowa
    Posts
    10

    Default Rear Right Turn Signal not working [Expired Topic]

    The rear right turn signal is not working on my van. I've checked the bulb, not that, and I couldn't find a bad fuse. Any ideas?

  2. #2

    Default

    recheck the bulb they get loose for some reason, did it twice to me

  3. #3
    Jr. Apprentice
    Join Date
    Aug 2009
    Location
    Coralville, Iowa
    Posts
    10

    Default

    Checked it several times, I don't get any voltage to the socket when the flasher is on. Its only the turn signal/brake light, the taillight portion works ok. And I have tried a new bulb to be sure.

  4. #4
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    What model?? year etc??
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  5. #5
    Jr. Apprentice
    Join Date
    Aug 2009
    Location
    Coralville, Iowa
    Posts
    10

    Default

    2009 2500 hd 4.8

  6. #6

    Default

    Check the tail light harness. I had the same problem on my 2002 silverado, and turns out my harness was just unplugged. Don't know how it got unplugged but, just plugging it back in, easily fixed the problem.
    www.youtube.com/ippielb
    2002 Chevrolet Silverado 1500 z71 1985 Chevrolet Silverado k10 2006 Chevrolet Silverado 2500hd 6.6l LLY Duramax
    6.5" BDS Suspension Lift Edelbrock Carb & Polished Intake Manifold & Valve Covers NAPC Race Transmission & NAPC Built Transfer Case
    EFI Live Comp Cam and Valvetrain Snow Performance Methanol Injection
    35" Toyo Open Country Mud Terrain on 18" Ion Alloy 179's Headman Long Tube Headers and True Dual Exhaust FASS 150gph Titanium Series Pump
    AirAid Cold Air Intake with K&N Dry Filter & AirAid PowerAid Throttle Body Spacer 2" Suspension Lift 33x12.50r15 Tires EFI Live & AFE Stage 2 Intake
    Pacesetter Long Tube Headers with Cats Gone True Dual Exhaust FlowPro 3.73 Gears Yukon Grizzly Locker with Mag-Hytec Cover & Traction Bars
    NGK Iridium Tips & MSD Ignition Plug Wires Baja Spare Tire Holder 33x13.5 Hankook rt03 18" XD Rims
    Innovate LC-1 Wideband o2 Sensor x2 HID's all around LED taillights and 3rd brake light
    BDS Dual Steering Stabilizers Pioneer Double-DIN Touchscreen Navigation with Two 10" Subs under rear seat
    Electric Fan Autometer Pressure, Boost, and Pyro Gauges
    4.56 Gears Airlift Air Bag Suspension

  7. #7
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Check your fuses since there are actually separate fuses for the lights.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

Similar Threads

  1. Driver's side turn signal not working.
    By jeffc in forum Member Introductions
    Replies: 5
    Last Post: 04-27-2009, 01:52 PM
  2. Driver's side turn signal not working.
    By jeffc in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 04-24-2009, 06:08 PM
  3. turn signal switch. [Expired Topic]
    By Burbski in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last Post: 05-23-2006, 07:26 PM
  4. Gauges not working- battery not charging [Expired Topic]
    By devildog29 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 05-15-2006, 08:36 AM
  5. Power window not working [Expired Topic]
    By tf5598 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last Post: 05-06-2006, 12:12 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •