GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default Couple of Qs about "new" suburban

    We recently got a 2003 suburban and there seems to be a few minor issues with it and I'm hoping for some help. (we had a '05 crew cab z71 silverado before this but didn't have these issues). The suburban is an 1500 LT with the autoride option.

    1) there is a fan type noise coming from this little plastic piece right above the driver seat in the headliner. It is about 2" diameter with a bunch of little holes in it....kinda looks like it could be a microphone, temperature sensor....I'm not sure what it is, but there is definatly some noise that is coming out of it. When I turn off the HVAC system it doesn't go away, so I don't think it has to do with that.


    2) there is a noise coming from the back of the engine/tranmission area while I'm driving. It kinda sounds like a bunch of quiet pinging, but it only does it when going faster than 40 mph and does it regardless of engine load (coasting, climbing hill, whatever)

    3) there is a "service air bag" light on the display....what do you do for this?

    4) The driver's heated seat doesn't work. The dealer replaced the switch, but it still doesn't work. He's supposed to fix it, but he doesn't really know what the problem is. I haven't looked at the wiring diagram yet to see if I can figure something out. Initially, it will turn on for about 3 minutes. After that it will only turn on for a few seconds before the lights turn off on the door switch.

  2. #2
    Sr. Engineer
    Join Date
    May 2009
    Location
    Manitowoc, WI
    Posts
    400

    Default

    Well, I can help with one of those. The little fan in the headliner is the temperature sensor for the automatic climate controls.

  3. #3

    Default

    Quote Originally Posted by Greg84 View Post
    Well, I can help with one of those. The little fan in the headliner is the temperature sensor for the automatic climate controls.
    That's what I thought....how do I make it stop making noise? Any ideas?
    '09 G8 GT: 6.0L
    '03 Suburban LT: 5.3L
    '68 C-10 Pro Touring resto mod: 5.3L/4L60E

  4. #4

    Default

    they'll start buzzing when the diaphram gets worn out inside. just replace it

    as far as the airbag you need to get the code. could be somthing unpluged or a shorted wire. look in the sdm module for a code.

    need more discription from the pining noise
    Last edited by Loggerhead Mike; 04-09-2010 at 01:27 PM.
    GM TECH

    05 silverado shortbed

  5. #5
    Sr. Engineer ahm1127's Avatar
    Join Date
    Jan 2009
    Location
    Pennsylvania, United States
    Posts
    320

    Default

    Answers to questions:
    1) there is a fan type noise coming from this little plastic piece right above the driver seat in the headliner. It is about 2" diameter with a bunch of little holes in it....kinda looks like it could be a microphone, temperature sensor....I'm not sure what it is, but there is definatly some noise that is coming out of it. When I turn off the HVAC system it doesn't go away, so I don't think it has to do with that. I had no idea, but glad someone else did!


    2) there is a noise coming from the back of the engine/tranmission area while I'm driving. It kinda sounds like a bunch of quiet pinging, but it only does it when going faster than 40 mph and does it regardless of engine load (coasting, climbing hill, whatever) I would look under truck for something loose like a wire, line or exhaust in & around the area described.

    3) there is a "service air bag" light on the display....what do you do for this? Went to GM dealer because most cant read it. Only asked for $50-60 dollars to check & didnt charge us because they replaced bad part. All electrical parts have to be programmed into computer so they are needed no matter what!

    4) The driver's heated seat doesn't work. The dealer replaced the switch, but it still doesn't work. He's supposed to fix it, but he doesn't really know what the problem is. I haven't looked at the wiring diagram yet to see if I can figure something out. Initially, it will turn on for about 3 minutes. After that it will only turn on for a few seconds before the lights turn off on the door switch. there must be a control module for it, switch with passenger side. Any difference with new switch? Check ground wire.
    Everyday I wake up is a great day! ;-)
    05' Chevy Suburban, 11' Ford Fiesta

Similar Threads

  1. Stock "P" rims safe with "LT" tire pressure?
    By xycarp in forum Wheels & Tires
    Replies: 2
    Last: 05-31-2010, 09:38 AM
  2. Need advice on a possible "new" truck, couple questions.
    By Falcone in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 10-21-2009, 04:05 PM
  3. Replies: 0
    Last: 06-21-2008, 12:30 PM
  4. Replies: 0
    Last: 07-24-2007, 12:30 PM
  5. "Monster Mash" Singer Bobby "Boris" Pickett Dies At 69
    By Cableguy in forum The Coffee Shop ~ Chit Chat
    Replies: 0
    Last: 04-27-2007, 10:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •