GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7

Thread: Died on me

  1. #1
    Jr. Mechanic
    Join Date
    Jan 2009
    Location
    Elizabeth City, NC
    Posts
    75

    Default Died on me

    Alright, I got a 1997 GMC Suburban with the 5.7. The other day I noticed it was starting to stumble a little at idle. It never shut off but it was dern close. Once I got in it and starting driving it was fine. No codes then. Well tonight it started doing it again, but worse and as I was driving. It would studder and then rev up on its own. Then it finally died. Now it has PO151, PO158, PO171, PO174. I know the first two are O2 sensors and then the second two are running lean codes. I can hear the fuel pump come on and it sounds fine. I just replaced it not too long ago. Will those O2 codes actually shut off the engine. I figured if they were bad then it would just run like crap, but actually kill it?? Anyway. I tried searching for it in the forum but everything seemed a little different.

    Forgive me for the length, and if anyone has any advice it would be greatly appreciated.

  2. #2
    Jr. Mechanic Sandhopper's Avatar
    Join Date
    Feb 2010
    Location
    Amarillo, Texas, United States
    Posts
    120

    Default

    Have you changed out the fuel filter? Not sure if there is an external fuel filter on the 97s but it might be a good place to start. Is is possible you may have gotten a bad tank of fuel? Maybe try some dry gas and or injector cleaner to treat the fuel system. How many miles are on it, and how long ago was the fuel pump changed? Just some more of my thoughts...

    2010 Suburban Z71 5.3 A6, Sheer Silver, Ebony Interior

    2004 Lexus RX330 AWD - Netune Blue Metalic

  3. #3
    Jr. Mechanic
    Join Date
    Jan 2009
    Location
    Elizabeth City, NC
    Posts
    75

    Default

    It does have an external fuel filter. I Changed the fuel filter about 3 weeks ago during an oil change. Fuel Pump was about 4 months ago. It has 108,000 miles on it. I had to get it towed to the house last night, but this morning it fired right up like nothing was wrong..... Still dont trust it.

  4. #4
    Jr. Mechanic Sandhopper's Avatar
    Join Date
    Feb 2010
    Location
    Amarillo, Texas, United States
    Posts
    120

    Default

    You still may want to check your fuel. If you have any moisture in it it may be freezing in the fuel line. Other than that maybe injectors???

    2010 Suburban Z71 5.3 A6, Sheer Silver, Ebony Interior

    2004 Lexus RX330 AWD - Netune Blue Metalic

  5. #5
    Jr. Mechanic
    Join Date
    Jan 2009
    Location
    Elizabeth City, NC
    Posts
    75

    Default

    Well, i changed out the fuel filter and it runs like a champ. Now I got a starting issue so I will let you know when I get that fixed and take it for a test drive.

  6. #6
    Jr. Mechanic Sandhopper's Avatar
    Join Date
    Feb 2010
    Location
    Amarillo, Texas, United States
    Posts
    120

    Default

    Sounds good. Glad you got it going again.

    2010 Suburban Z71 5.3 A6, Sheer Silver, Ebony Interior

    2004 Lexus RX330 AWD - Netune Blue Metalic

  7. #7
    Jr. Mechanic
    Join Date
    Jan 2009
    Location
    Elizabeth City, NC
    Posts
    75

    Default

    Took it for a test drive and she runs great. Amazing what a clogged fuel filter will do to ya.

Similar Threads

  1. My tranny died...UGH
    By trapper_canada in forum GM Powertrain
    Replies: 2
    Last Post: 02-19-2010, 06:04 PM
  2. Died while driving?
    By kingkevin8 in forum Chevy C/K Truck Forum
    Replies: 4
    Last Post: 12-06-2009, 11:03 AM
  3. Truck Died
    By al96chev in forum General Chevy & GM Tech Questions
    Replies: 12
    Last Post: 11-18-2009, 11:31 PM
  4. It just died
    By Gbav1 in forum GM Powertrain
    Replies: 7
    Last Post: 02-11-2009, 07:04 PM
  5. Ted Rogers has died at the age of 75
    By Cableguy in forum The Coffee Shop ~ Chit Chat
    Replies: 3
    Last Post: 12-02-2008, 02:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •