GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Unhappy A/C and Cabin lights will not come on...fan blows?

    I own a 2000 Chevrolet Silverado with 146,XXX miles, I was installing a CB through my glove box light by splicing them in. I accidentally had both of the wires touch + and - touched in the glove box. I checked my fuses and they were all fine! Now because of this my cabin lights will not turn on in the doors, floor board, or my cargo lamp. My dash lights work, and reads CARGO LAMP ON.

    Another problem not associated with this is my A/C, the fan works but no cold air blows out, Ithought it needed a recharge and tried charging it, yet when the pressure read it was above 500 psi! FTW! I know there is froen in there on account of me being able to feel it numbing my fingers when trying to charge it through the port.

    I don't see the frost or condensation like I usually would on the unit in the engine bay. Fuses were fine and knobs are functional.

    Any help would be more than appreciated!

    Kind Regards to the Community,



    Kevin
    Last edited by kev409; 04-07-2010 at 10:34 AM.
    - Kevin :yipi:





    "I need help" is a common phrase....and I use it alot! LOL.

  2. #2
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    Hi kev-

    I'd check the fuses again, a different way than you did the first time. If you pulled one or two out and did a visual I'd get a meter and check the top sides of the fuses one by one, it should only take about 3 minutes to do them all. Also....I'm not sure if it would affect only a small portion of lights in the truck, you might want to check the fuses under the hood. May have had one of those go out although I think one of the smaller fuses in the cab would have popped first.

    I can't help with the A/C... good luck with it and your electrical problem!
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




  3. #3
    Sr. Apprentice
    Join Date
    Nov 2009
    Location
    Grandview, WA
    Posts
    68

    Default

    On the A/c Part have you checked the pulley/ clutch on A/C compressor? The whole unit should turn with the a/c on. If the middle part does not turn, your clutch could be bad or power to the clutch.

Similar Threads

  1. Help!!! Hvac only blows cold air??
    By r_anderson65 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 12-04-2009, 05:16 PM
  2. rear lights indicators Internal fuse blows
    By bensdive in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 02-22-2009, 07:25 AM
  3. A/C blows warm in my '99 'Burban
    By hihoslva in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 07-28-2008, 09:10 PM
  4. A/C always blows?
    By MWright936 in forum Audio, Video & Gadget Tech
    Replies: 5
    Last: 05-21-2008, 07:15 PM
  5. Vent blows warm air
    By bgbird in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 03-28-2007, 08:22 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •