GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10
  1. #1

    Default 97 Suburban Intermittent No Start

    My 97 K1500 4x4 5.7L 176,000 miles has not started on two occasions (three weeks apart), most recently yesterday. It starts later and is ok, but seems to crank a little longer before starting (all the time). It also backfires when starting (very infrequently - less than once a month).I have replaced the crank poision sensor and fuel pump relay, as well as recent cap, rotor, plugs, wires, fuel filter.

    My system doesn't hold fuel pressure, with key on (but not running) pressure goes to 45 psi, but drops to below 10 psi in about 30 seconds.

    Any ideas?
    Last edited by getawaycars; 04-11-2010 at 11:39 AM.

  2. #2

    Default

    Maybe you should set the timing, idk if it would cause low fuel pressure but it would cause backfires and prolonged starting.


    1995 Chevy Silverado
    Fully loaded!!!
    4Wheel Drive
    5.7 Liter
    Blue
    Best Engine In The World!!!!!
    Once i had a nearly dead battery and was only able to get 1 slow crank per attempt, Once to the fifth crank she fired up! (True Story)
    ________________________________________
    Do you have a Tahoe,Yukon or a suburban? Join My Group
    http://www.gmtruckclub.com/forum/group.php?groupid=26

  3. #3

    Default

    The backfiring could be a timing issue, the fuel pressure drop happened to me in my 2000 1500. had to replace the fuel pump. apparently it is a common problem among the later 1500's.
    '00 1500 4x4 4.8l
    single glasspack
    daily driver/workhorse

  4. #4

    Default

    Update: Last Friday the truck wouldn't start again and had to be towed. I had to replace the fuel pump. That fixed the no start issue. However, it still is dropping fuel pressure. It still seems to crank a little longer than expected, but has been running fine so far. I will update again if anything changes.

  5. #5
    Jr. Apprentice
    Join Date
    Mar 2010
    Location
    Maryville, TN
    Posts
    18

    Default

    Quote Originally Posted by getawaycars View Post
    Update: Last Friday the truck wouldn't start again and had to be towed. I had to replace the fuel pump. That fixed the no start issue. However, it still is dropping fuel pressure. It still seems to crank a little longer than expected, but has been running fine so far. I will update again if anything changes.
    Assuming that your new fuel pump is a good one, I can think of 2 possible problems. Maybe you have a bad fuel pressure regulator and it leaks pressure back to the return line or one of the fuel injectors is leaking. Do you know if anyone has worked on the fuel injectors? Do you have the orig. style injectors or have they been updated. One of the factory service bulletins talks about performing a fuel injection cleaning ( not the stuff you put into the gas tank ) and then if the problem still exists, they start checking the injectors.

    I have a 99 K1500 Suburban (same engine and body style as your 97). To get to the fuel injectors, you have to remove the upper intake plenum. Then you will see what looks like a spider. The fuel injectors are all in one big body, then there are 8 plastic tubes with poppet valves at the end of each that clip into the intake manifold, just above each intake valve.

    The plastic tubes tend to get brittle over time and crack (ie. leak) and then the poppets can get stuck open. It can cost big bucks to fix the orig. system. The dealer was able to look up a replacement unit which came as an entire assembly. The new unit has the injectors placed at the end of larger tubes, so rather than holding them all together and routing the fuel, it sprays like a more modern injector.

    The cost was less than 1/2 of the cost of replacing the orig. style injectors and tubes piece by piece.

  6. #6

    Default

    I replaced the injectors with the aftermarket (upgraded) multiport injectors. I would recommend this to anyone. The truck starts right up, runs great, no more check engine light (due to rich codes) and one mpg improvement. Definetely worth the time and money.

  7. #7

    Default

    you said you used aftermarket injectors (upgrsded) who did they come from? Napa ,carquest or?

  8. #8

    Default

    Standard Motor Products part number FJ504. You should be able to get this from a non-chain auto parts store.

  9. #9

    Default

    getawaycars,
    did you replace the spider yourself? I see the spider online for around $400. I have access to a good military auto hobby shop and wonder if it's something I could do myself.
    Fred
    KonaBurb, '97 K1500, 147K, Stock

  10. #10

    Default

    Fred,

    I have about 8 yrs experience as a mechanic (although it took place in the '80's) and I found it to be a challenging project which took about 6 hours. The most complicated part was disconnecting and labeling everything connected to the upper intake.

    What is a miltary auto hobby shop and your experience level?

Similar Threads

  1. intermittent no start
    By sagags in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last: 01-20-2010, 09:22 PM
  2. 97 Suburban will not start HELP!
    By doo600 in forum Chevy C/K Truck Forum
    Replies: 1
    Last: 10-27-2009, 03:36 PM
  3. Intermittent Start Problem
    By eglmrk in forum General Chevy & GM Tech Questions
    Replies: 6
    Last: 03-14-2008, 01:00 PM
  4. 95 Suburban no start
    By jtferris in forum GM Powertrain
    Replies: 6
    Last: 12-31-2007, 07:20 PM
  5. 97 Suburban Won't start
    By ChaosEnvy in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last: 10-22-2007, 11:27 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •