GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default 92 suburban won't start- ignition problem?

    The symptoms were turning the key and it wouldn't click, you turn key off and on a few times and it would fire up. I thought it was the solenoid on the starter was going bad. So I replaced the starter after it just wouldn' start anymore.(It has a new battery btw). Just found out I can turn the igniton without a key in it from off to start position... So I'm thinking I need a new ignition switch... unless there is something else I'm missing? I did check the ignition fuse and it is good.

  2. #2
    Sr. Apprentice dannys99's Avatar
    Join Date
    Mar 2010
    Location
    Northern California
    Posts
    71
    Blog Entries
    4

    Default

    I think you best bet is to start with the ignition switch like you said.
    "If I were lie'n I'd be cry'n and I aint shed a tear"

  3. #3
    Jr. Mechanic Sandhopper's Avatar
    Join Date
    Feb 2010
    Location
    Amarillo, Texas, United States
    Posts
    120

    Default

    I had an 88 Jimmy that was so worn that it did not need a key and started fine. You may want to look at the wiring from the battery to the Starter. I read a post a few weeks ago that turned out to be a wiring issue. Here is what he found.

    Quote Originally Posted by Allmostsmart View Post
    Ok. I fixed it!!!! I wired the switch up and it didn't work either but it sounded like the solenoid was working just fine. It was the Cable that ran from the Battery to the starter. I had 12 volts on it at the starter but when I took the cable off and ran a continuity check on it it had 6.5 ohms of resistance!! Built up a new cable and threw it on there and it worked like a champ. New Cable has 0.1 ohms of resistance. Much better. Thanks Guys.

    2010 Suburban Z71 5.3 A6, Sheer Silver, Ebony Interior

    2004 Lexus RX330 AWD - Netune Blue Metalic

  4. #4

    Default

    thanks for the wiring option will check that first. I have never replaced an ignition switch...how difficult is it?

Similar Threads

  1. Suburban Ignition Switch/Instrument Cluster Problem?
    By JAL1959 in forum GM Electrical Tech
    Replies: 10
    Last: 10-27-2012, 12:04 PM
  2. Possible electrical or ignition problem. 2003 Yukon XL ~160K mi.
    By yukonstein in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 07-20-2010, 04:24 PM
  3. Ignition problem/Can't turn off truck with key!?
    By bradyjames in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 07-07-2010, 10:30 AM
  4. 99 Suburban Ignition Woes
    By redfishnc in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 03-21-2010, 12:04 PM
  5. HELP!!! Ignition Problem?? 99 Surburban 5.7
    By mbaxter in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 02-13-2010, 09:31 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •