GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: loss in power

  1. #1

    Default loss in power

    recently i have noticed a loss in power in my 5.3 2000 silverado. when i floor it, it used to kick in and go like a beast. but now it just feels like its just in a high gear trying to go...doesnt want to downshift either. now probably only 25% of the time it would kick in and go, maybe less even
    suggestions?

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    do you have a CEL??? When was the last time it was serviced??
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    I have seen some other posts that were similiar in nature.

    Turned out to be the TPS sensor.
    Pavement sucks... :grrrrrr:



    1994 K1500 4x4 Ext. Cab
    PCM chip and Xenon 8000k bulbs
    350cu.in bored over .050"
    balanced Crank, 10:1 compression
    Flat top pistons,cam,ported heads
    Option Racing Cold Air Intake
    Holley Throttle Body Spacer
    Accell Igition, 45kv coil
    FloTech Headers, no CATs, dual exhuast
    Goodyear Silent Armor A/T 305/70-16
    Pioneer SupertunerIII CD USB Bluetooth
    Kicker ZX200.2 ZX Amp
    Kicker Audio COMP 10" Subwoofer

  4. #4

    Default

    Quote Originally Posted by murdog94 View Post
    do you have a CEL??? When was the last time it was serviced??
    CEL? im not sure what that is. and i did a tune up a couple months ago. around dec-jan

  5. #5
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    check engine light.. and X2 on the possible TPS (throttle position sensor)
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  6. #6

    Default

    Quote Originally Posted by Silverado1500 View Post
    CEL? im not sure what that is. and i did a tune up a couple months ago. around dec-jan
    What did you do for a tuneup? What brand wires, plugs, plug gap?
    When you hear hoofbeats, look for horses not zebras.

  7. #7

    Default

    Quote Originally Posted by 2COR517 View Post
    What did you do for a tuneup? What brand wires, plugs, plug gap?
    oil, oil filter, air filter, bosch irridium plugs, ac delco wires, fuel filter, cleaned throttle body.

  8. #8

    Default

    Quote Originally Posted by murdog94 View Post
    check engine light.. and X2 on the possible TPS (throttle position sensor)
    i dont have a CEL when i start the engine, how could i check the TPS sensor? and how much do these go for?

  9. #9

    Default

    i dont think the tuneup had anything to do with it, because it just started happening.

  10. #10

    Default

    Dump the Bosch plugs, they are garbage. Get some AC Delco plugs, Platinum or Iridium, your choice. Just be sure the gap is .040"

    A fuel filter would be a wise investment.
    When you hear hoofbeats, look for horses not zebras.

Page 1 of 2 12 LastLast

Similar Threads

  1. Loss Of Power
    By Pratt in forum GM Powertrain
    Replies: 6
    Last Post: 07-30-2010, 12:30 AM
  2. Loss in power . No CEL
    By Danow in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 07-12-2010, 11:07 AM
  3. Loss of Low end power
    By CBaker350 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 05-24-2010, 05:14 PM
  4. A/C On - Loss of Engine Power
    By wrodriguez in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 6
    Last Post: 11-20-2007, 02:32 PM
  5. Low end power loss
    By Dukeu21 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last Post: 08-16-2006, 02:58 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •