GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Hybrid View

  1. #1
    Jr. Mechanic 95Chevyk1500's Avatar
    Join Date
    Dec 2009
    Location
    Maine (so yes, I can ride a moose)
    Posts
    100

    Default Weird Tranny issue

    I ave a 97 c1500 with a 4.3 and an automatic transmission. Just under 160k. i have a pretty strange problem with the transmission. after i drive around 30 miles, shifting from 1st to second it slams into 2nd. if i restart the truck it shifts fine. its wierd because normally it shifts as smooth as a brand new truck. Im thinking do a flush and filter change. Im just cofused on this one because like i said when you restart the truck it wont do it
    1997 Chevy c1500
    Regular cab Shortbox
    4.3 Automatic (wish it was a 5 speed, but i'll get over it)
    157k miles

  2. #2

    Default

    You have a very common problem and in fact the most common with the 4L60E. What is happening is the transmission is going into failsafe mode. When this happens the PCM raises the line pressure which gives you a harsh 1-2 shift. Probably a worn out TCC regulator valve in the valve body. Don't waste your money changing fluid. Instead go get your truck scanned for trouble codes.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  3. #3
    Jr. Mechanic
    Join Date
    Mar 2010
    Location
    Montana
    Posts
    134
    Blog Entries
    1

    Default

    My 97 z71 was doing that too right before i took it in to get the trans fluid changed.With my truck they guy broke open the trans filter and found all kinds of clutch packing in it. I replaced the trans and the truck still did it from time to time. I have a little over 50 k on the new trans and it does it every once in a while now but not as bad. When i talked to the shop that did my trans they said its normal.I dont think it is my self so if you take it in go to a shop you can trust.

  4. #4
    Jr. Mechanic 95Chevyk1500's Avatar
    Join Date
    Dec 2009
    Location
    Maine (so yes, I can ride a moose)
    Posts
    100

    Default

    Quote Originally Posted by Jimmiee View Post
    You have a very common problem and in fact the most common with the 4L60E. What is happening is the transmission is going into failsafe mode. When this happens the PCM raises the line pressure which gives you a harsh 1-2 shift. Probably a worn out TCC regulator valve in the valve body. Don't waste your money changing fluid. Instead go get your truck scanned for trouble codes.
    ya i read about that after i posted this. i think i can replace the tcc and it wont be too bad
    1997 Chevy c1500
    Regular cab Shortbox
    4.3 Automatic (wish it was a 5 speed, but i'll get over it)
    157k miles

Similar Threads

  1. Tranny issue with 1996 silverado
    By 96BlackSilverado in forum GM Powertrain
    Replies: 4
    Last Post: 03-17-2010, 11:02 AM
  2. 2005 Silverado tranny issue
    By schrinediggity in forum GM Powertrain
    Replies: 0
    Last Post: 04-16-2009, 09:38 AM
  3. 2003 Chevy Silverado 2500HD Tranny Issue?
    By Chevy2500HD in forum GM Powertrain
    Replies: 0
    Last Post: 08-28-2008, 07:30 PM
  4. Tranny issue
    By Willow9238 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last Post: 03-15-2008, 11:10 PM
  5. Weird Issue with 07 Silverado
    By ctruhn in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 9
    Last Post: 07-02-2007, 11:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •