GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default 01 Suburban 8.1 dies

    Howdy. I have a 2001 4x4 Suburban with 8.1 and 4l80e. The engine dies at random: sometimes it will just kill for half of a second then run again, sometimes die and not start until it feels like it. The last time I drove it for 3 miles, it prolly died 10 times. The majority of the time I had to restart with the key, but sometimes would kill and run again. hmmmm

    It has 133K miles and the trans. was just replaced with new GM at GM dealer. I am not pointing a finger, but it seems as though this started after trans. was replaced.

    I am pretty sure it is electrical cuz of the ' kills and then continues running' bit.

    I have not put a gauge on it, but fuel pressure relief valve burps fuel in the air.

    Any ideas?

    Thank you, Travis
    01 Suburban 2500 LT 4X4, 8.1L
    95 Taurus SHO, 80K, 5 sp, many mods

  2. #2
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default Coolant temperature sensor

    No magic fix, just basic troubleshooting. Check the fuel pressure to eliminate the fuel pump/pressure regulator. You didn't mention if it was throwing any Codes. Might help start you in the right direction if it was. Check the coolant temp sensor. It can throw the fuel mixture off. Usually will run too rich and cause sluggish or non-op condition.

    Do a search in these forums on "coolant temperature sensor"
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

  3. #3

    Default

    Sorry. I assume no codes. The ck. engine is not on, but I have not checked.

    I did not search coolant temp. sensor.

    Thank you.
    01 Suburban 2500 LT 4X4, 8.1L
    95 Taurus SHO, 80K, 5 sp, many mods

Similar Threads

  1. '02 Suburban dies under load / power
    By kbroderick in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 10-21-2010, 10:40 AM
  2. 2004 Suburban dies while driving
    By skiboat in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 06-28-2010, 05:06 PM
  3. Vehicle Dies
    By crfarrow in forum Chevy Colorado Forum (GMC Canyon)
    Replies: 1
    Last Post: 02-17-2010, 09:18 PM
  4. HOLY C&*%!!! 89 Suburban dies when I turn on my headlights!!!
    By Big6ft6 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 18
    Last Post: 01-06-2010, 08:42 PM
  5. 2004 Suburban Dies on the highway
    By jsamotis in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 09-05-2008, 09:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •