GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Cool '04 Silverado, 4.8L, rough idle, no codes set ?

    hi all, need some help

    (new here, but not new to basic maintenance of vehicles... I'll be 60-yrs old next month)

    Purchased a 2004 Chevy Silverado 1500 (reg. cab, 8 foot bed, 4.8L, no frills), with 97,400 miles on it, on the 5th of this month. Today (May 14th) I did the following:

    * Cleaned MAF Sensor and Throttle Body.

    * Replaced all Spark Plugs with Autolite Double Platinum copper-core APP5245s (they came gapped at 0.055). I regapped them to be 0.040 (the old ones were APP5245, gapped as indicated below). All of the old plugs were NOT tightened/torqued as they should have been... and #1, #3, and #6 were less than finger-tight!

    1 - 0.063
    2 - 0.065
    3 - 0.067
    4 - 0.065
    5 - 0.064
    6 - 0.063
    7 - 0.067
    8 - 0.064

    All of the plug wires looked to be in good condition, and they read between 910 ohms and 945 ohms of resistance... so I left them on the truck. I reinstalled everything using a bit of anti-seize on the plug threads and dielectric grease on the plug boots.

    A bit of a rough idle (no codes set) and noticeable hesitation were the reason for my under-takings as noted above. After completing the above... there is no hesitation and the idle is almost smooth (way better than it was before I started).

    With no codes set, and no CEL indications, I presume I should just drive it for a bit to see if the idle will completely smooth out. On FORD products I have owned & worked-on, one could disconnect the battery... short the POS and NEG battery cables (NOT the battery terminals!) together, for about five minutes. This would completely RESET the computer, and once power was hooked-up again... the first 10-miles / 10-minutes or so of driving would allow the computer to "relearn and optimize" the system.

    QUESTION:

    I'm curious if CHEVY has an "adaptive" computer (anything like the FORDs)?

    Is there anything else I should look at (given "no codes set") and a not "perfectly smooth idle"?

    TIA - karl

  2. #2

    Default

    Ok -- I've driven it for a few days now without doing anything further to it. It seems to be running just fine (perhaps I was just being overly sensitive to any variations in the "idle"?). But the original "rough idle" and "hesitation" have caused me to be a believer in the saying "trust no one"!

    This vehicle was serviced by a FORD dealer in DE, apparently not long before it was bought at auction (by the used car dealer, in Southeastern VA, from who I bought it). It started just fine... and while warming-up the idle seemed fine (I suppose), but as the engine reached operating temperature that's when the "rough idle" became more noticeable (while sitting at stop lights, for example).

    One thing is for sure... whomever changed the plugs did NOT gap them properly, neither did they torque them properly. IOW: "trust no one" (do it yourself, if you are capable)!

  3. #3
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Agreed, also have you tried the seafoam trick since your near 100K that might help to clean things out further.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  4. #4

    Default

    Thanks for the feedback!

    When I first noticed the "rough idle" I did clean both the MAF sensor and the Throttle body:

    I cleaned the MAF Sensor using CRC Mass Air Flow Sensor Cleaner and the Throttle Body using Sea Foam Spray. I've not used any other products for those chores, but I am open to suggestions.

Similar Threads

  1. Replies: 4
    Last Post: 07-25-2010, 10:17 PM
  2. Rough Idle...No Codes
    By Seany Z in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 10
    Last Post: 07-20-2010, 02:26 PM
  3. 01 Silverado, rough idle
    By rbeneventi in forum GM Powertrain
    Replies: 3
    Last Post: 04-14-2010, 05:35 AM
  4. 2004 Silverado running rough idle/stalling out
    By KuttingEdgeInteriors in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 02-23-2010, 09:58 PM
  5. Rough Idle, Loss of Power. Had codes checked but now need help on where to go!
    By JEM2121 in forum General Chevy & GM Tech Questions
    Replies: 9
    Last Post: 09-11-2009, 12:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •