GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1
    Sr. Apprentice Schwindle's Avatar
    Join Date
    Aug 2009
    Location
    Bremerton, WA
    Posts
    33

    Default Clicking during acceleration...

    I recently have had a problem with a loud clicking coming from underneath my truck when I accelerate. When I get on the highway it either goes away or I can no longer hear it. From what i've found from a little research that it is more than likely my U-joints. But Im still not convinced. Any input would be appreciated...
    KYLE

    Washington
    2002 Chevy Tahoe Z71 5.3L V8
    Diablosport Performance Programmer
    6" Tuff Country Lift, 20" Ultra's, 35" TOYO Open Country A/T's
    Jet Performance TBS, K&N Cold Air Intake, Magnaflow Cat-Back Exhaust

    BLACK BETTY

  2. #2
    Jr. Mechanic
    Join Date
    Mar 2010
    Location
    Montana
    Posts
    134
    Blog Entries
    1

    Default

    is it coming from the motor ? My 97 5.7 had what i thought was a ping from the motor when ever i got on it hard. I put in different gas from a different station and it took care of it.

  3. #3
    Sr. Apprentice Schwindle's Avatar
    Join Date
    Aug 2009
    Location
    Bremerton, WA
    Posts
    33

    Default Nope...

    Fixed it today actually. It was the U-joints and had I gone prolly five more miles I would have been in need of a tow truck... Thanks though.
    KYLE

    Washington
    2002 Chevy Tahoe Z71 5.3L V8
    Diablosport Performance Programmer
    6" Tuff Country Lift, 20" Ultra's, 35" TOYO Open Country A/T's
    Jet Performance TBS, K&N Cold Air Intake, Magnaflow Cat-Back Exhaust

    BLACK BETTY

  4. #4
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Hopefully you got a set of greasable ones since the stock u-joints dont come with them and they wear out pretty quickly sometimes.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  5. #5
    Sr. Apprentice Schwindle's Avatar
    Join Date
    Aug 2009
    Location
    Bremerton, WA
    Posts
    33

    Default

    Actually when it comes to precision **** like that I usually just have someone else do it. So I took it to a machine shop specializing in drivelines. Its was this older fella who works out of his basement awesome dude took care of it all for me. The grease able ones are set in place.
    KYLE

    Washington
    2002 Chevy Tahoe Z71 5.3L V8
    Diablosport Performance Programmer
    6" Tuff Country Lift, 20" Ultra's, 35" TOYO Open Country A/T's
    Jet Performance TBS, K&N Cold Air Intake, Magnaflow Cat-Back Exhaust

    BLACK BETTY

Similar Threads

  1. Bad acceleration
    By 97Tahoe in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 7
    Last Post: 07-22-2010, 09:53 PM
  2. Lag in Acceleration
    By 1998SilveradoGuy92 in forum GM Powertrain
    Replies: 11
    Last Post: 03-02-2010, 02:02 PM
  3. Clicking under acceleration??
    By bad5300 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 05-12-2009, 07:19 AM
  4. Issues with Acceleration
    By Rado2001 in forum Performance & Fuel
    Replies: 4
    Last Post: 10-08-2008, 03:30 PM
  5. Lag in low end acceleration
    By bigwill20021 in forum GM Powertrain
    Replies: 1
    Last Post: 08-11-2008, 12:03 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •