GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 13
  1. #1
    Master Mechanic HawaiiKid's Avatar
    Join Date
    Feb 2010
    Location
    Honolulu, HI
    Posts
    537
    Blog Entries
    12

    Default Oil Pressure fluctuation?

    Hey guys,
    So about a week or 2 after I changed my oil, I have noticed something strange with my oil pressure. Whenever I start it up, the gauge jumps right up to around 40, and stays there, which seems like its normal operating pressure. However, whenever I rev the engine, the pressure gauge responds to my acceleration by going UP. I have looked around, and everything I have seen in other threads has been about the pressure going DOWN as people accelerate...so what could be causing this? I read somewhere that it could be that there isn't enough oil in the engine (even though the oil line on the dipstick is right in the middle of the shaded area), anything else that would cause this?

    Thanks guys,
    Billy

    2003 Silverado, SOLD 1/11/11 for my... 2001 Ford Mustang Bullit, #1787

  2. #2
    Sr. Engineer Joethepoolguy's Avatar
    Join Date
    Feb 2010
    Location
    Leon, NY
    Posts
    437
    Blog Entries
    3

    Default

    Your oil pressure SHOULD go up when you hit the throttle. The more RPMs the engine turns,the more the oil pump turns. When the engine is cold, you will have more oil pressure then when its warmed up,too. At 40psi...that sounds right.

    2004 Silverado 2500HD LT 4x4 QuadraSteer
    6 liter w/ Comp Cam
    Stainless Steel Headers
    K&N Panel Filter W/Airbox Mod
    A/C Iridium Spark Plugs
    SCT Power Programmer
    MPT Custom Tune
    MagnaFlow Dual Exhaust
    Cobra 29 LTD Bluetooth CB
    Custom Badges
    3" Rear, 2" Front Rough Country Suspension Lift
    33x12.5x33 M/Ts

  3. #3

    Default

    Quote Originally Posted by HawaiiKid View Post
    Hey guys,
    So about a week or 2 after I changed my oil, I have noticed something strange with my oil pressure. Whenever I start it up, the gauge jumps right up to around 40, and stays there, which seems like its normal operating pressure. However, whenever I rev the engine, the pressure gauge responds to my acceleration by going UP. I have looked around, and everything I have seen in other threads has been about the pressure going DOWN as people accelerate...so what could be causing this? I read somewhere that it could be that there isn't enough oil in the engine (even though the oil line on the dipstick is right in the middle of the shaded area), anything else that would cause this?

    Thanks guys,
    Billy

    I don't mean to be rude or anything, but I believe you are use to Fords, huh?
    I've always owned Fords up until now, and their oil pressure gauges don't move at all. They are pretty much "Dummy Gauges", where it tells if you have pressure, or you don't.
    Chevrolet Gauges seem to actually "work", for a lack of better words..
    2012 Silverado 1500
    2004 Silverado 1500 (SOLD): http://tinyurl.com/JRD761sTruck
    1977 Silverado C20:
    http://tinyurl.com/JRD761-1977-C20

  4. #4

    Default

    Mine has always gone up when revving or increasing speed. Only at around 40 at idle otherwise up closer to 60
    David
    2004 Silverado 2500 Crew Cab 4x4, AMSOIL EA air filter, Granatelli MAF sensor, Throttle body spacer, Magnaflow exhaust (true dual to 2 in 1 out muffler), 6" ProComp lift (add a leaf and 5" superlift rear block), Bilstein shocks, 35's (Cooper Disoverer ST) and 4.10 gears, Rhino Liner, EGRUSA fender Flares and widow visors, extended stainless steel brake lines, firestone airbags w/onboard air compressor, Pioneer Avic X940BT navigation, Accel backup camera.
    http://www.gmtruckclub.com/forum/sho...Silverado-2500
    1960 Land Rover Series II 88
    2001 Pontiac Sunfire
    2013 Toyota Avalon Limited (Wife's Car)
    NRA Life Member

  5. #5
    Master Mechanic HawaiiKid's Avatar
    Join Date
    Feb 2010
    Location
    Honolulu, HI
    Posts
    537
    Blog Entries
    12

    Default

    Yeah, I understand that its normal...but it hasn't happened until now, so its not "normal" for this truck with me. The one thing I forgot to mention is that this movement of the oil pressure also coincided closely with the lost of my muffler...you think there might be some correlation? Either way I'm getting a new set up put on tomorrow, exhaust wise.

  6. #6

    Default

    The motors in trucks like yours were not designed to operate near coconut trees. Chances are there has been a reaction between the coconut particulate present in the air and the oil passages in your engine. Since you have lost your muffler, the coconut particulate has found a direct path into your engine. Your best bet will be to completely disassemble your engine and clean these passages with Q-tips.

    When you spin a pump faster it puts out more fluid. The oil in your engine is circulated with a PUMP. Increasing the RPM of your engine spins the pump faster. The friction induced by the flow of oil through the engine makes it more difficult for the pump to output this increased volume of fluid. Since it cant output as much....pressure goes up.

  7. #7
    Master Mechanic HawaiiKid's Avatar
    Join Date
    Feb 2010
    Location
    Honolulu, HI
    Posts
    537
    Blog Entries
    12

    Default

    Quote Originally Posted by LT1Chevy210 View Post
    The motors in trucks like yours were not designed to operate near coconut trees. Chances are there has been a reaction between the coconut particulate present in the air and the oil passages in your engine. Since you have lost your muffler, the coconut particulate has found a direct path into your engine. Your best bet will be to completely disassemble your engine and clean these passages with Q-tips.

    When you spin a pump faster it puts out more fluid. The oil in your engine is circulated with a PUMP. Increasing the RPM of your engine spins the pump faster. The friction induced by the flow of oil through the engine makes it more difficult for the pump to output this increased volume of fluid. Since it cant output as much....pressure goes up.
    Thanks...I've never heard a Hawaii joke before, must be that everyone is jealous of the fact that my state is nicer than theirs... Good thing I actually live in New York right now, as my info says...

    And like I just said, it hadn't happened up until now, so I was wondering if there might be some reason to be worried since it just started happen. Also, having the muffler replaced did nothing to "fix" the problem.

  8. #8

    Default

    Maybe you had a glitchy gauge and it is now working...40 psi at idle is healthy and the quicker it get's there the better.also it should climb when you hit the throttle not drop.sounds like your motor is healthy to me.Just remember more oil faster is good.


    03 Chevy Silverado 1500 ext cab Z-71
    79 AMC Spirit GT
    77 Olds cutlass supreme

  9. #9
    Jr. Mechanic
    Join Date
    Aug 2009
    Location
    Lockport, NY
    Posts
    102

    Default

    My 2009 just hit 6000 miles and at idle when cold it hits right around 50 psi, and revs up to around 60 "cold". As it warms up, it drops at idle to just under 40 psi and goes to just under50 psi at normal road speeds and RPMs..so a drop of about 10 psi when it is warm at normal operating temps on average is what I have noticed.
    I did notice a difference with the first oil change however..I had it done at the store here and they put in bulk oil for the first change. We are suppose to be selling BULK Mobile 1 oil..but I did notice about a 5 psi drop in the oil pressure with that oil change with a new AC filter put on it.
    At 5000 miles I DID the change myself with a Wix filter and Mobile 1 in 5W-30 and I am back UP to the normal oil pressure levels I started with.
    Each of these trucks with a 5.3L in them that I start on the lot, new from the factory seems to follow these pressure levels.
    Unless you changed the oil yourself you can never really be sure what is put in it. But it sounds to me like you don't have any problem at all.
    Good luck with your truck.

  10. #10
    Master Mechanic Dr_Zero's Avatar
    Join Date
    Mar 2006
    Location
    Sunny Florida
    Posts
    706

    Default

    Quote Originally Posted by HawaiiKid View Post
    Hey guys,
    So about a week or 2 after I changed my oil, I have noticed something strange with my oil pressure. Whenever I start it up, the gauge jumps right up to around 40, and stays there, which seems like its normal operating pressure. However, whenever I rev the engine, the pressure gauge responds to my acceleration by going UP. I have looked around, and everything I have seen in other threads has been about the pressure going DOWN as people accelerate...so what could be causing this? I read somewhere that it could be that there isn't enough oil in the engine (even though the oil line on the dipstick is right in the middle of the shaded area), anything else that would cause this?

    Thanks guys,
    Billy

    Did you use a new brand of oil filter?

    Reason I ask is I have had the same thing happen on my wifes truck when I put on a Napa Gold filter which is made by Wix.

    To test the idea when I got my oil changed I put on a Wix instead of the Purolator PureOne Filter and I had the same thing happen.

    Im wondering if the filter is more restrictive causing higher pressures or if its the design of the bypass valve and drain back valves???

    I have no clue but I have tried 2 engines with the same outcome so I can reproduce the effect so I know it not just a fluke.
    My trucks!

    1996 GMC Suburban SLT
    1997 GMC Yukon SLT

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. 1989 suburban coolant temp fluctuation
    By Big6ft6 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 16
    Last: 04-09-2010, 10:15 PM
  2. Low oil pressure!!
    By vncj96 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 12-26-2008, 09:47 AM
  3. Oil Gauge Fluctuation
    By vanimal in forum GM Powertrain
    Replies: 3
    Last: 10-07-2008, 01:45 PM
  4. oil pressure
    By caprice88 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 8
    Last: 11-18-2007, 11:44 PM
  5. oil pressure fluctuation
    By craplee in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 7
    Last: 12-23-2006, 10:01 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •