GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 12
  1. #1
    Master Mechanic
    GM_Guy's Avatar
    Join Date
    Jan 2007
    Location
    kansas
    Posts
    743

    Angry what happened??????

    as I was coming home in my 82 GMC van early this am, I was preparing to turn in my driveway, engine suddenly quit, and now will not re start. it simply cranks (kind of fast), will not fire. it was running very good up until it quit. I have to get it pulled in to my yard first before I can remove the outhouse, to look at the engine. what went wrong??????
    Jeff

    1968 Chrysler Imperial Crown 4 door ht ~ resto project
    1984 Buick Le Sabre 4 door sedan~daily driver






    BUY ONLY GENUINE ACME PRODUCTS



  2. #2
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    Busted flexplate maybe.
    Although engines don't usually stall from that, they just don't ever start again.
    Can you hear the engine turning over, or just the sound of the starter spinning quick.
    Can you see if your distributor rotor spins when you crank it.
    Patrick
    Rhode Island


  3. #3
    Master Mechanic
    GM_Guy's Avatar
    Join Date
    Jan 2007
    Location
    kansas
    Posts
    743

    Default

    I will have to check when I get it pulled in my yard,it's sitting on the street now
    I did a quick check,and the engine is turning over,(put mark on alt fan, it moved after cranking it for a sec) can't do much else to it where it sits now. was running smoothly before it happened

  4. #4

    Default

    fuel pump? Pop the line and see if any fuel comes out. I've had this happen before, mind you on a FoMoCo. Driving down the road it it just died without warning.
    Last edited by ChevyFan; 03-28-2007 at 08:57 AM.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

  5. #5
    Master Mechanic
    GM_Guy's Avatar
    Join Date
    Jan 2007
    Location
    kansas
    Posts
    743

    Default

    I got it pulled in the yard, rotor is turning, and is getting fuel. pulled a plug wire, and stuck a plug in to it, and placed it close to ground, I saw no spark. so, I'll pull the module first, and see if it's bad
    Last edited by GM_Guy; 03-28-2007 at 10:19 AM.

  6. #6
    Moderator

    Davandy's Avatar
    Join Date
    Jun 2005
    Location
    Haasdonk Belgium
    Posts
    1,550

    Default

    I bet my money on the module
    Peter Smet
    Haasdonk, Belgium

  7. #7

    Default

    Ok I'll bite. Cap, rotor and module.



    Jamie

    2007 Ford E250(Work van) (Ya, Ya, shut up!)
    1996 GMC Sierra SLE 1500 5.7L/4L60E

  8. #8
    Master Mechanic
    GM_Guy's Avatar
    Join Date
    Jan 2007
    Location
    kansas
    Posts
    743

    Default

    was the module. took it to have tested, failed miserably.
    put a new one in, runs great again!!

  9. #9

    Default

    Quote Originally Posted by Jeffs89Suburban View Post
    was the module. took it to have tested, failed miserably.
    put a new one in, runs great again!!
    Good for you she's alive again! What did me and Davandy win

  10. #10

    Default

    At least it failed near home. I've broken down 1000 miles from home before while I was going away to work for the summer. Not fun.

    Glad you're back in the saddle again!

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Just changed oil, strange thing happened...
    By BrokeEnthusiast in forum General Chevy & GM Tech Questions
    Replies: 22
    Last: 03-16-2010, 04:58 PM
  2. th400 dumped tranny fluid all over the highway. What happened?
    By Big6ft6 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last: 11-03-2009, 11:38 AM
  3. Has this ever happened to anyone
    By rod in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 07-01-2008, 05:30 PM
  4. So, what might have happened to my battery?
    By captainstormy in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 02-13-2008, 10:48 AM
  5. What ever happened to the console build?
    By 84fiero123 in forum Announcements & Feedback
    Replies: 8
    Last: 08-16-2006, 07:44 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •