GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Need Help Voltage drops and engine stalls when brakes are applied

    I went to drive my truck today and started it up and when I hit the brakes it dies sometimes and is hard to start back up. Is it a vacuum leak in the brake system?

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Sounds like you have a vacum leak.. is the CEL on?? If so the codes might help some.. Since the IAC and or else the TPS might not be communicating and increasing the idle when you hit the brakes.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

Similar Threads

  1. Engine Stalls and Only Will Restart With Pedal To The Floor
    By coffmaad in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 09-30-2009, 10:12 PM
  2. Replies: 0
    Last Post: 07-12-2009, 09:20 AM
  3. TBI starts then stalls, gas held slowly stalls
    By TigerZ in forum Chevy C/K Truck Forum
    Replies: 2
    Last Post: 09-02-2008, 02:27 PM
  4. Engine stalls with throttle increases
    By Dr. E. in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 4
    Last Post: 07-11-2008, 03:36 PM
  5. engine stalls
    By gregk in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 06-27-2008, 09:48 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •