GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 3 123 Last Post byLast Post by
Results 1 to 10 of 21
  1. #1

    Default After Header Problems...

    So, after i installed my headers, and got my exhaust done. I've noticed since AFTER i got my exhaust done, my truck idles EXTREMELY low. Low as in almost killing the engine. 400 rpm range. I've fixed my o2 sensor's wiring, so they're all going the proper directions.
    www.youtube.com/ippielb
    2002 Chevrolet Silverado 1500 z71 1985 Chevrolet Silverado k10 2006 Chevrolet Silverado 2500hd 6.6l LLY Duramax
    6.5" BDS Suspension Lift Edelbrock Carb & Polished Intake Manifold & Valve Covers NAPC Race Transmission & NAPC Built Transfer Case
    EFI Live Comp Cam and Valvetrain Snow Performance Methanol Injection
    35" Toyo Open Country Mud Terrain on 18" Ion Alloy 179's Headman Long Tube Headers and True Dual Exhaust FASS 150gph Titanium Series Pump
    AirAid Cold Air Intake with K&N Dry Filter & AirAid PowerAid Throttle Body Spacer 2" Suspension Lift 33x12.50r15 Tires EFI Live & AFE Stage 2 Intake
    Pacesetter Long Tube Headers with Cats Gone True Dual Exhaust FlowPro 3.73 Gears Yukon Grizzly Locker with Mag-Hytec Cover & Traction Bars
    NGK Iridium Tips & MSD Ignition Plug Wires Baja Spare Tire Holder 33x13.5 Hankook rt03 18" XD Rims
    Innovate LC-1 Wideband o2 Sensor x2 HID's all around LED taillights and 3rd brake light
    BDS Dual Steering Stabilizers Pioneer Double-DIN Touchscreen Navigation with Two 10" Subs under rear seat
    Electric Fan Autometer Pressure, Boost, and Pyro Gauges
    4.56 Gears Airlift Air Bag Suspension

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Have you reset the computer??? Seems that the IAC isnt being opened far enough Or to far since there is more flow and less pressure..
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    I will try that. I totally forgot about doing that! Thank you.

    Here's a video of my truck idling.


  4. #4

    Default

    Tried resetting the computer. Didn't do a thing. On to the next fix thing... What is the next thing?

  5. #5
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Is the CEL lit?? Or was it at least before you reset the computer?? Also have you cleaned the IAC or anything along those lines?? Since the IAC can get carbon in it and be stuck further open than needed/ or else be plugged up some and with the increase in outflow you might need a bit more on the inflow...

  6. #6

    Default

    Check engine light was on before i swapper headers. i reset the computer, and cleaned the idle valve, still idles very low. And i just found this out tonight, but when i stomp on it. my exhaust is like it's cold outside, moisture in it. My truck must be running extremely rich for it to pour fuel out the ass end like that.

  7. #7
    Jr. Mechanic
    Join Date
    Apr 2010
    Location
    Ortonville MI
    Posts
    136

    Default

    I see that it says you removed your Cats did you tune them out? I know some motors will run like **** if you take them off and dont tune them out. They will run as if the choke is on with a carbed motor.

    07 NBS Crew cab SLT 4x4

  8. #8

    Default

    Had my cats cut of 5 months prior to putting long tube headers on and it ran fine without them. Just putting the headers on caused it to run sloppy.

  9. #9
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    backpressure issue, how big of pipes did you start with and what did you step up to. If you have too big of diameter the exhaust wont flow as well and this could be the cause for the extra moisture in your exhaust as it is cooling more because it doesnt have the same velocity in the smaller diameter pipe
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  10. #10

    Default

    Started with 2.5" pipe, ended with 2.5" pipe.

Page 1 of 3 123 Last Post byLast Post by

Similar Threads

  1. Header help
    By mitchlbuck in forum GM Powertrain
    Replies: 7
    Last: 05-28-2010, 11:42 AM
  2. Header Mod
    By lifted98chevysilverado in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last: 05-03-2010, 08:09 PM
  3. Header question!?!
    By BLKDOUTZ in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 04-27-2010, 02:32 PM
  4. Replies: 1
    Last: 04-19-2009, 09:29 PM
  5. HEADER
    By doug in forum Chevy Colorado Forum (GMC Canyon)
    Replies: 2
    Last: 07-23-2006, 05:40 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •