GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 99 s-10 a/c probs

    I have a 2.2L 99 s10 pickup and have not had working a/c in it for some time. I was inspecting around the engine and opened up the fuse box in under the hood and found a busted red fuse for the a/c, I replaced it and the a/c worked! but after going down the road I got back in my truck and turned it off and the a/c isn't working again: the fuse is already blown.
    What would cause this to happen and how can I fix it?

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    You have a short somewhere. Take a look for a ground etc...
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

Similar Threads

  1. 2005 silverado tranny probs
    By bigproskine in forum GM Powertrain
    Replies: 5
    Last Post: 11-22-2010, 08:55 PM
  2. 93 Step Side PROBS!!!
    By babybtch_tx in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 02-17-2010, 01:54 PM
  3. Carb probs. 85 4x4
    By maw454 in forum GM Powertrain
    Replies: 1
    Last Post: 02-25-2009, 03:29 PM
  4. 6.2 diesel probs
    By 83Sub in forum Chevy C/K Truck Forum
    Replies: 9
    Last Post: 11-26-2008, 08:17 PM
  5. havin some tranny probs
    By rocco 87 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 04-24-2008, 02:00 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •