GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1
    Jr. Apprentice
    Join Date
    Jun 2010
    Location
    Augusta, GA (for now)
    Posts
    12

    Unhappy looking for some tech support

    Has any one taken a TBI 350 out of a late 80's truck and replaced it with a Carb small block? I am having fuel pump issues after putting 300 miles on the truck. The fuel pump runs when you turn the key on but aftger 15-20 seconds it turns off. The electric is shut off to the pump... confused on why it didnt do this right after the swap...

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Sounds like you might have lost your fuel pump relay? And the pump is supposed to shut off when it reaches the proper pressure until it needs more pressure. With out the injectors and computer monitoring everything there might not be signal being sent after it reaches the proper pressure.. Most people who swap these motors to carb, replace the electrical fuel pump with a mechanical or a low pressure fuel pump not mounted in the tank.. When they replace with either they take the pump out and run a pick up tube in place of the pump to keep their guage working.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3
    Legend
    Eddie Z71's Avatar
    Join Date
    Mar 2009
    Location
    Colorado Springs, CO
    Posts
    3,838
    Blog Entries
    1

    Default

    Hi, and welcome to the site! Glad to have you here! Looks like murdog94 has some great advice! Keep us posted! Good luck!
    Eddie , 2000 Chevy Tahoe Z71 (old style)

  4. #4

    Default

    Welcome to the GMTruckClub!


    2010 Z/71 Colorado C/C
    Black 4X4 w/5.3L V8
    ===============
    2007 Winnebago Adventurer
    w/8.1L Chevy & Allison 6spd.
    Canyon Lake, Texas

  5. #5
    Jr. Apprentice
    Join Date
    Jun 2010
    Location
    Augusta, GA (for now)
    Posts
    12

    Default

    Thanks for the Reply, I stuck with the in tank pump because I have two tanks and with about 6 MPG I want to stick with both tanks. I think I am just going to rewire the system adding a relay that comes from the ignition to my selector switch relay. I shouldnt have any problem that i can forsee. Whats you guys (and girls) advice?

Similar Threads

  1. Replies: 0
    Last: 02-17-2010, 05:10 PM
  2. Help support me fight kids cancer
    By lawson4450 in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last: 02-27-2009, 10:37 PM
  3. Replacement hard tonneau lift support
    By UndaCuva in forum Chevy Truck Accessories
    Replies: 2
    Last: 03-05-2008, 04:59 AM
  4. need radiator support for 2002 envoy
    By crazyphong in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 8
    Last: 01-20-2007, 02:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •