GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1
    Sr. Apprentice socal77k5's Avatar
    Join Date
    Mar 2010
    Location
    Orange County
    Posts
    72

    Default 87 suburban shifting issues?

    ok i have a 87 suburban 5.7 liter. i just replaced the fuel regulator in the tbi, the filter and the in tank fuel pump. now out of absolute nowhere the transmission wont get out of first, it will go in reverse nuetral and park but wont go through the driving gears. i noticed im now missing something from my tbi, all thast connected is my accelorator, the none of the other 2 connecting spots have anything going to them, what am i missing and is it because oif this that i cant shift?
    1987 Chevy Suburban 4x4 - Lifes a garden, dig it, gotta keep on keepin on!


  2. #2

    Default

    Sounds like your T/V (throttle valve) cable came off.......
    Joseph


    Airforce Veteran (7 years)


    NRA Life Member

Similar Threads

  1. Suburban issues!
    By artlock in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 07-30-2009, 02:38 PM
  2. k2500 not shifting - electrical issues?
    By carl s. in forum Chevy C/K Truck Forum
    Replies: 1
    Last Post: 05-24-2009, 09:53 PM
  3. '97 Suburban A/C Issues
    By KonaBurb in forum Chevy SUV & Crossover Tech Forum
    Replies: 1
    Last Post: 10-30-2008, 10:12 PM
  4. 99 Suburban Issues
    By ljjcsauto in forum GM Powertrain
    Replies: 4
    Last Post: 05-31-2008, 07:56 AM
  5. Suburban brake issues
    By tbplus10 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 9
    Last Post: 03-16-2007, 09:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •